Java Loader and Apache security enabled


How can I specify the userid and password to use when using the Java loader.

I Apache security activated (ex. user = ‘tamino’ and password = ‘tamino’).

I have unload/load procedures to copy data from one Tamino database to another one. This procedure works fine until I have a Tamino server to be connected via an Apache with security activated. Then I receive always HTTP 401 (authorization required) messages. This is a normal reaction, because I never specified a user/password to be used making the HTTP connection.

Using Parameter -user and -passwd works for unloading data but when you try to load data you will get the error you described. Have you ever try inoxmld ?

… <BR> -unload <BR> -u http://…. <BR> -query /name <BR> -format loadRequest <BR> -encoding “iso-8859-1” <BR> -user “name” <BR> -passwd “password” <BR>


Great Stuff!

How come I didn’t find -user / -passwd in the documentation?

As of Tamino 4.1.4, the load operation also works!

And if you just specify -user, inojload will ask for the password and mask your input on the commandline - so some security for your password there …

Best regards, Andreas