Issues with pub.flatFile:convertToValues when iterate=true


I observed that we have issues with public service pub.flatFile:convertToValues when iterate is set to true. The issue is when the ffStream has mix of valid and invalid records and on looping through if invalid record is encountered isValid is returned as “false” and even if other subsequest nodes/records are valid this flag remains “false” for those records which is incorrect.

SAG claimed to resolve this issue in FF_Fix_2 (for FF 6.5 module) but seems this issue is still there for newer versions? has anybody encountered this and got it resolved?


I don’t recall versions in use but I too ran into this error where once isValid is false it never became true again. We applied a fix but I don’t recall the fix number. :frowning:

We are facing the same issue and our version is 7.1. Very interested to see if the fix has indeed worked for any one you…

Found the details.

WmFlatFile v

There may be equivalent fixes available for 6.5.

I did applied IS_7.1.2_CoreFix32, but issue still persist? did you recall any other adjustment you made after applying the fix…

I recall only that after applying the fix that it started working. The fix explicitly mentioned this issue so maybe you can review the readme for CoreFix32 to make sure it has the change.

Alas, I also ended up removing record validation from my solution so I ended up not relying on the fix being present. :frowning:

Update on this issue: SAG accepted this bug even in coreFix 32 and they are claiming that they have solved it in next core fix (33) scheduled to be released on 18th Feb, 2011…