Issues with MWS after 7.1.3 to 9.5 upgrade

Hi All,

Not sure if I should be posting this here or on the MWS forum, but this is the first list of errors that I can see after I ran the migration utility on the new 9.5 installation. The migration utility ran without any error. The server also starts up, but with a lot of errors.

One of the issues is that Administrator cannot see anything but a few error messages like below.

2014-04-10 14:41:42 EST (Framework : INFO) [RID:47] - [POP.003.0025] administrator cannot view the content of Leftnav.
com.webmethods.portal.mech.access.PortalAccessException: [POP.003.0025] administrator cannot view the content of Leftnav.
        at com.webmethods.portal.mech.view.impl.ViewableMechanics.checkView(

The sysadmin can log in and see a few more pages. BUt even sysadmin cannot see a lot of pages and I can see the following error on the screen.

[POP.003.0025] sysadmin cannot view the content of Basic Search.

I found that the basicsearch.pdp file is missing.

(Framework : FATAL) - ERROR installing: wm_PowerDrillHead.cdp. Required component is not installed or available for install: wm_basicsearch.pdp

Can someone provide that pdp file? How to fix this issue?

Thanks and Regards,
Ninad Patil


did you run a “ -s default upgrade” after installation of the new MWS?

“default” is the name of the MWS-Instance.

The command will modify the database with the new versions of the portlets.
Most likely this will do the trick.

If not, please open an support incident with SAG support.


Thanks for the reply Holger,

I tried that, but unfortunately, I get the following message indicating “upgrade” is not a valid option:

Invalid action: upgrade
 My webMethods Server

I solved this issue by copying over wm_basicsearch.pdp from 713 instance. But I am not sure if this is the right way or if this particular file should even be present in MWS 9.5.

Do I need any special installation instruction for the “upgrade” option?

Ninad Patil

Even i tried to run the Migration utility from 8.2.3 to 9.5 but it did not move everything…

In these cases it willl be considerable to open an incident with support team and get this checked.

Hopefully they have already a plan how to solve this.


Hi Ninad,

It looks like the issue is similar to an issue which we have encountered during MWS migrate to 9.6. The jetty.xml file gets updated [multiple sections of the file gets commented out] after upgrade. Uncommenting the following sections in the jetty.xml file may help in resolving this issue:
• http listener (nio)
• http listener (blocking)
• https listener (nio)
• https listener (blocking)

Hope this helps.