Issue with services disappearing despite services exist in teh ns folders.

Hi All,

I am currently experiencing an issue with services not being displayed in developer and not even recognised in the integration server. I tried to install the package again and still no luck. I tried to delete the package and copied the same package from another integration server but still the issue is the same?

Can anyone please help? Please also note that the issue is being encountered on webMethods version 6.5?

Thanks for your help.


The issue that was encountered was that some services were missing and also we could not create any jdbc adapters since we were getting the error java.lang.NullPointerException and aslo caffeine error.

We tried to add the WMJDBC package as dependcy pacakge in the requested package and also did try to reisntall packages but it did not help.

Finally with the help of software AG, the cache file in the datastore folder of the integration server was deleted when the server was down and server was started again. Issue was fixed and services were redeployed from our QA environment.