Issue with pub.soap.utils:getXOPObjectContent ..... MTOM objects

hi All ,

We are developing wrapper service for SMTP which has to be exposed as webservice , where we need the attachments to be obtained using MTOM . (pub.soap.utils:getXOPObjectContent)

Now when we are running the service from SOAP , we are not getting any contents in the email attachment .

We have enable attachment property to "TRUE " in webService and and MTOM property as TRUE in "SOAP UI " .

Any help and thread on this topic will be helpful .

Thanks
Mithilesh Kumar

What is the content-type you set for receiving attachment?

Also do you have any WmMtomStreamingSample package to compare your settings?

HTH,
RMG

Im setting the content type which is being returned by the pub.soap.utils:getXOPObjectContent service.

Hello,

From your post I did not understand if you want to create a MTOM enabled WS provider or a consumer.
Can you please clarify this?

If you want to create a MTOM enabled provider you might need to make also some setting on the Integration Server.
Like the ones below:
watt.server.soap.MTOMStreamiong.enable=true
watt.server.SOAP.MTOMStreaming.cachedFiles.location = leave it to the default location
watt.server.SOAP.MTOMStreaming.threshold = leave it to the default value

However, like it was specified above the WmMtomStreamingSample (in the attachment) is an excellent way to start.

Please also note that in soapUI, you need to make the following settings:
Enable MTOM: true
Disable Multiparts: false

You can use a traffic monitoring and sniffing tool (I used Wireshark) to check that actually the call was done using MTOM streaming.

Hope this helps!

20121231122616508_000_MTOMStreaming.zip (259 KB)

Hello,

From your post I did not understand if you want to create a MTOM enabled WS provider or a consumer.
Can you please clarify this?

If you want to create a MTOM enabled provider you might need to make also some setting on the Integration Server.
Like the ones below:
watt.server.soap.MTOMStreamiong.enable=true
watt.server.SOAP.MTOMStreaming.cachedFiles.location = leave it to the default location
watt.server.SOAP.MTOMStreaming.threshold = leave it to the default value

However, like it was specified above the WmMtomStreamingSample is an excellent way to start.

Please also note that in soapUI, you need to make the following settings:
Enable MTOM: true
Disable Multiparts: false

You can use a traffic monitoring and sniffing tool (I used Wireshark) to check that actually the call was done using MTOM streaming.

Hope this helps!

20121231122616508_000_MTOMStreaming.zip (259 KB)

Hi Vlad,

Sorry for my late reply…
Thanks a lot for your help and your files.

In fact, the other problem I’ve met (and maybe linked) is described here and this time, do not interact in any way with a consumer step :
http://tech.forums.softwareag.com/techjforum/posts/list/56150.page

Maybe would you have any idea ?

Regards

Hi,

I have downloaded WmMtomStreamingSample.zip from here. But for some reason when i installed on my Integration Server, I do not see subfolders under the package. am I doing something wrong? can anyone please advise?

Thanks
Chandra.

Hi Chandra,

There can be a lot of reasons why the assets are not shown.
Here are a few tips:

  • check if the version of the package and your wM version match or are compatible
  • check if the package is fully loaded
  • if not check the errors/warnings
  • check the server.log for errors when the package is reloaded
  • reload the package

Hope it helps,
Vlad Turian

1 Like

I am really new to this so please bear with me. I too am not seeing anything after the installation. When I look at the Package Information, it shows that 0 Elements were loaded and 0 Elements were not loaded. It also indicates that there were no load errors or warnings. So… exactly how do I check the version of the package and check my wM version and how do I determine if they are compatible?

Hi Joe,

Well, the package was created using webMethods 8.2.

You can check your IS version using the following steps:

  1. Access the IS on http://<>:5555
  2. In the upper right corner click on About
  3. Check for Version in the page that opens (like in the picture)

The compatibility issues might be the ones that prevent the package from loading.

You can check the community is there is a sample with your version.

I am planning to do also a blog post on this on http://wm-explorer.com, but this will be probably just next month.

Have you checked the “MTOM Streaming” chapter from the Web Services Developers guide?

Best regards,
Vlad Turian

version.PNG

Hi Joe,

please check server.log for error messages during package loading.
There should be a message for your package with reference to missing or disabled packages or incompatible package versions on which your affected package depends.

See package overview page for dependency informations (also available via manifest.v3 file in the package directory).

Regards,
Holger