Issue with Local Service Development

We are using local Service Development feature for version control.

I have a problem, everything works fine except checkout. When i go to package explorer and click on “Move project to IS package”, it doesnt work.

Am i doing anything wrong, can anyone please tell me, Below is what i have done.

  1. Using the Local dev feature.
  2. Svn


Hi Anjaneyulu,

please provide your wM version.

Which SVN plugin for evlipse are you using?
Subclipse or Subversive?

Are there any error messages which might be helpful for us?


Thanks Holger for the Reply,
Below are details,

wM version 9.12
SVN plugin version - subversive svn 1.7 version 3.03
I do not see any errors when i click on “Move project to IS package” some refresh happens but thats it i dont see anything.

Also i followed the pdf to set my dev.


Hi Anjaneyulu ,

The package which you checked out was probably manually committed or someone who committed it from designer workstation , ignored the .project file.
That’s why the context menu of “Move Project to IS Package” is not coming. Get a .project file from a package which has been checked out and loaded propery in IS , Place it where your package(which is missing .project , generally available under workspace folder) has been checked out and refresh the package explorer view.

Then you will be able to get the desired option.

Hi Rakesh,
Sorry Dint get your point,

Below is what i did

  1. I created a package
  2. Commit it and its visible in repository.
  3. I open designer of another user.
  4. Open the repository.
  5. Check out the package to the local workspace.
  6. Once it is local workspace, i right click and click on “Move Project to IS package” from Package explorer view.
  7. The package is not visible in the IS, so unable to figure out what is going wrong. DOnt see any error messages either.


  1. Commit it and its visible in repository.
    [Rakesh] : How did you commit your package? using designer or manually?

[Rakesh] : are you seeing any .project file present inside the Package folder in repository ?

Did the commit from Designer
and yeah i am able to see .project file.

Also, to add:
After your first reply i check all the files except .project, when i did this i was able to “ADD VCS Project Nature”. Once i add that, i clicked on “Move Project to IS Project”. Still it doesnt work.


Did you checkout the package after committing the .project file ?

Can you please checkout the package again , refresh and then see if the “Move Project to IS Project” option is enabled or not.

Did that as well still nothing happens
Some how i feel i am missing something, i do see “Move Project to IS project” and its enabled as well, Problem is when i click on it server refresh happens but package is not loaded from local workspace.

Had couple of doubts:

  1. Is there a need to configure some property which tells eclipse to put the package in IS and reload.
  2. Or should i place this package in package directory inside Integration server package directory.


No need of any extra settings or configuration.

Can you please check the following :

  1. Are you getting any error on server.log while loading the package to IS. May be this package is dependent on some other package.
  2. Ensure that the watt.server.ns.lockingMode parameter is set to system on the Integration Server used as the local development server.
  3. A local development server is an Integration Server instance that is installed in the same installation directory as the Designer instance you are using. The local service development feature works with the local development server only.
  4. If there are multiple Integration Server instances configured, only one instance will be active at a time. The default Integration Server instance will be treated as the default local development server.
  5. You must add VCS project nature to the packages that are not created in the local Integration Server but are available in t he VCS if you want to copy or move these packages to Integration Server. To do this, right-click the package in the Package Explorer view and select Add VCS Project Nature.

Yup i followed all the steps, those were mentioned in Service Development help guide.

  1. No error in server log.
  2. Yup made that setting.
  3. Yup, Designer and IS are in same Instalation directory.
  4. Yup doing the same
  5. Yup did that also.

No success yet


  1. Can you check one more thing , if the package folder already exist on the <IS_Directory>/packages ?
  2. I suppose your workspace directory and <IS_Directory>/packages directory are different . Please confirm

Got your point, it works now :D.

I made my IS package directory as workspace directory.

Thanks a lot for the help.


I did not say that (IS package directory and workspace directory should be same) , you can have different workspace directory and still the “Move Project to IS Package” option should work.

  1. From your VCS repository, get the latest version of the package that you want to copy to your Integration Server_directory \instances\default\packages directory.
  2. Designer copies the package to your workspace.
  3. In Navigator view, right-click the package and select Move Project to IS Package. The package is now available in the Integration Server_directory\instances\default\packages directory.

Oh okie, i thought so :slight_smile:

Till now i have been doing the three steps that you mentioned.
and i can see Move Project to IS pacakge when i right click, but it doesnt work, the package does not move.

Also there is no log as well, i increased the logging mode to see any inputs but dint see any error message or any message related to packages.

But when i took the workspace and mapped it to Package directory, it works.


It’s been a long time. I hope the issue is fixed at your end. But just in case, if someone looks for the solution. SoftwareAG has come up with a fix that apparently solves the issue for this version and onwards. Please look for it via your update manager under local service development, and you should be able to find it.