IS not starting up

Hi ,

we are trying to start IS in our development server but we are getting the below error in server log . Please provide your suggestions to resolve this issue.

2010-04-12 13:05:10 GMT+03:00 [ISS.0095.0010E] AuditLogManager Runtime Exception: >>>BasicData:RootContextID=e1517430461a11dfab9ba66a5bfcee50,AuditTimestamp=1271066710772,ContextID=e1517430461a11dfab9ba66a5bfcee50,AuditSchemaName=wMSession,AuditSchemaVersion=1,ServerID=ruebnkdev:8888,SessionID=e0a92640461a11dfab978f5edffe5556,SessionState=2,UserID=Administrator,SessionName=system,Rpcs=0,Age=1103<<< publishing log entry [BAA.0002.0000] Wrapped Exception: [BAT.0002.0000] Wrapped Exception: com.wm.txn.TransactionException: [BAC.0002.0000] Wrapped Exception: com.wm.txn.TransactionException: [BAC.0002.0000] Wrapped Exception: [BAF.0002.0000] Wrapped Exception: com.wm.util.BasisRuntimeException: [BAF.0001.0060] Type mismatch: empt != null on <0000003a> empt r0 *00000003 p0000003a n00000056 k00000000 d00178bbb (D 0) .
2010-04-12 13:10:07 GMT+03:00 [ISS.0128.0009E] Unable to get JDBC Connection to the database.
2010-04-12 13:10:07 GMT+03:00 [ISS.0128.0002E] Exception while deleting expired uuids: [ISS.0128.9002] Unable to get Connection
2010-04-12 13:11:17 GMT+03:00 [ISS.0025.0001C] Integration Server Build 124
2010-04-12 13:11:17 GMT+03:00 [ISS.0025.0006I] License Manager started
2010-04-12 13:11:18 GMT+03:00 [ISS.0025.0041I] FIPS mode not initialized
2010-04-12 13:11:23 GMT+03:00 [ISS.0025.0050W] The Unlimited Policy File was not found. Please install it.


Did you run out of disk space? This is most likely to be a problem with corrupted audit store.
I would backup your current IntegrationServer/audit/data files, delete them and try to start IS again.

IS creates empty stores if they are not found when starting up.

Else review your jdbc pools or raise a support request with wM.


Is the DB up and running? If you setup your audit datastore as a database rather than a file then IS expects the DB to be up and running. This issue is valid only for IS 7.1.2 and later.


Hi ,

Thanks for all your suggestions .

We have checked that the database is up and running and even started the IS server in safe mode . We have changed the expiration period of the master password and tried to restart the IS but We got the below errors while startup IS

2010-04-13 08:29:36 GMT+03:00 [ART.0114.1100I] Adapter Runtime: Facility 800 - EntireX Adapter registered with bundle com.softwareag.entirex.wmadapter.EntireXAdapterResourceBundle.
2010-04-13 08:29:36 GMT+03:00 [ADA.0800.0105E] WmEntireX: cannot read trace level: ./packages/WmEntireX/config/entirex.trc (No such file or directory (errno:2))
2010-04-13 08:29:36 GMT+03:00 [ADA.0800.0100I] WmEntireX Adapter 12 Mar 2009 12:33:04 is starting
2010-04-13 08:29:36 GMT+03:00 [ISS.0028.0012I] WmJDBCAdapter: Startup service (wm.adapter.wmjdbc.admin:registerAdapter)
2010-04-13 08:29:37 GMT+03:00 [ART.0114.1100I] Adapter Runtime: Facility 1 - JDBCAdapter registered with bundle com.wm.adapter.wmjdbc.JDBCAdapterResourceBundle.
2010-04-13 08:29:37 GMT+03:00 [ADA.0001.0701W] Exception while creating “SampleConnectionProperties.xml”

Looking forward to your valuable suggestions.


Seems like some parameters has changed in the sampleconnection (JDPC pool alias) , go into WebmethodsInstallationDir/IntegrationServer/config/jdbc/pool/

delete the sampleconnection**.xml file from there and try to bring up the IS then… it should work, if not reply back with the errors.


Hi ,

I checked the directory /Webmethods/IntegerationServer/config/jdbc/pool
but there are only two xml files present which are DBconnPool.xml and Embedded Database Pool.xml and no other files are there.


Do you have can have insalled anything like WmSampleAdapter** package in your enviornment? you can check in by browing thorugh packages directory… you can disable that.
Try to restart IS by removing DBpool.xml file…

Just to add, after removing the file, edit the files from the function directory as well which are using this connection pool.



I was facing a similar issue and your reply really helped solving the issue. Thank You so much

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.