Invalid credentials - IS - APIG

Product/components used and version/fix level:


Detailed explanation of the problem:

After the installation of an IS API Gateway, I’ve encountered an issue where I’m unable to access either the IS or the API Gateway. The error message I’m receiving is: “Could not login. [ISS.0084.9001] Invalid credentials.”

Despite multiple installation attempts, I continue to encounter the same error. I have even changed the password for the Administrator account, and checked require the password to be changed on the first product login.

I also tried modifying the configuration using Command Central, but unfortunately, I was unsuccessful.

Could you please provide some insights into what might be causing this problem? Is it possibly related to the Integration Server Core 10.15 Fix 10 (PIE-87135 / PIE-86166)?

Thank you for your assistance in advance.

Error messages / full error message screenshot / log file:

Question related to a free trial, or to a production (customer) instance?

These kind of bugs (if it is a bug) are usually fixed in early fixes, so installing the latest fixes is usually the easiest thing you can try to fix the issue. If it is not a bug, its probably a caps lock or different keyboard layout error (during the installation or password change). You can reset the password by manually updating /opt/softwareag/IntegrationServer/instances/default/config/users.conf. You need to update it when integration server is shut down and it will encrypt it next time you run the integration server.

Thank you for providing the solution. I tried following your suggestion and manually updating the users.conf file while the Integration Server was shut down. However, unfortunately, this approach did not resolve the issue. I still encountered the same error message upon attempting to access the IS API Gateway.

Where do you get that error? When trying to access admin UI? or when making calls from API gateway to Integration Server? If it is the first one, it should fix your issue. If it is the second one, you need to provide/update credentials.

As long as you have platform manager running on the node that you are trying to update, this should have worked. If it didn’t may be you are successfully updating the credentials. Can you explain further what you are trying to do? If you are able to connect both admin UIs, that means you are successfully updating the credentials.

Yes, I encountered the error when attempting to access the admin UI. Upon entering the credentials and trying to log in.
on the other hand I don’t see any error in the server.log file

During installation, there is a step where your set up a password for the Administrator. Are you certain that you are using this password when you logon?

Before setting this password during installation, type it out in a Notepad on the remote server (or wherever you’re installing), and copy-paste it from the Notepad. If you still experience an issue, copy-paste this password in the browser as well, after start-up.

If you still get an access denied, even with the above attempts and latest fixes (I must add that this is extremely unlikely, and often points to a human error somewhere), then for lack of a better way to investigate this via the forum, I recommend a support ticket.


Thank you for your response. Yes, I am certain that I am using the password set during installation when attempting to log in. I also followed your suggestion and copied the password directly from a text editor during both installation and subsequent login attempts. Despite these precautions, I am still encountering the same error message.

There is no way this update procedure can fail. Even if everything fails, this should work. Did you install latest fixes? Try making the password simple first to verify it. If you can’t login even after updating this file, then there must be some other issue that is preventing your login. I recommend creating a support ticket if the issue still persists.

While the API Gateway runs on an IS it doesnt use the same mechanism for authentication as the IS. So you cannot change the password in the user.cnf file and hope it works. The passwords are stored in the elasticsearch datastore. Here are things that could be wrong:

  1. You set a different password during the install. Unlikely as you stated that you have done it multiple times.
  2. Your IS is not able to connect to the InternalDataStore. If that happens you should see a bunch of errors in the server.log file. Look for something related to GatewayInternalTechnicalUser. Also check for the processes running on your system to see if the elasticsearch instance is running. A file named in the InternalDataStore/bin folder should also be an indication. But if you dont see the process running then delete this file and try to restart the InternalDataStore before trying to log in again.

Rupinder Singh