Installer 8.0.1 on Ubuntu 9.04 AMD64

Hi all,
I just spent some time trying to install a previously downloaded image of webMethods 8.0 for Linux AMD64.

Initially I was always getting the following message when trying to start the installer with the native (i.e. 64 bits) jvm:

“The webMethods Installer server you chose does not support this platform. Choose a different server.”

All I was doing was trying to start the installer like this:

$ java -jar webMethodsInstaller801.jar

Then I tried to use a 32 bits jvm like this:

$ /usr/lib/jvm/ia32-java-6-sun/bin/java -jar webMethodsInstaller801.jar

It let me run the installer, but when selecting the image file (through “Advanced Options…”) it always returned this error:

“The image file does not support this platform. Choose a different image.”

After increasing the debug level of the installer and inspecting the log file, I noticed that it uses the “uname -p” command and that it wasn’t able to determine the platform it was running on. I tried to run the “uname -p” command myself and discovered that indeed it always return “unknown”. I’m not sure about other Linux flavors (RedHat et al) but on Ubuntu this always seems to be the case. Anyways, I knew that “uname -m” would return the correct value so I replaced the uname command with a script that runs “uname -m” instead of “uname -p”, after that the installer runs happily in it’s simplest form (java -jar webMethodsInstaller801.jar) and I was able to install wM 8 easily.

To do the same all one needs to do is follow these steps:

  1. Rename the existing uname executable
    $ sudo mv /bin/uname /bin/uname.orig

  2. Create the following script and save it as /bin/ (e.g. $ sudo vi /bin/

if [ $1 = “-p” ] ; then
uname.orig -m
uname.orig $@

  1. Create a symbolic link from /bin/uname to /bin/
    $ sudo ln -s /bin/ /bin/uname

After this the installer will run smoothly. If you ever need to “disable” this workaround and use the original uname command just change the symlink like this:

$ sudo ln -sf /bin/uname.orig /bin/uname

and to change it back:

sudo ln -sf /bin/ /bin/uname

I hope this helps.



Thats an excellent tip i should say… i always had a doubt whether we can install wm on ubuntu(never tried though, not that comfortable with linux/ubuntu), but always wanted to.

can you pls help with below questions:

  1. did you install oracle database on ubuntu
    a) if so what version is it
    b) were you able to connect all components of webMethods products to oracle database@ubuntu

Thank you

Fantastic! Will try this out soon! Have always wanted to run webM on Ubuntu which is by far the most widely used desktop distro out there. Not as clunky as RedHat or CentOS in my opinion. Also more user friendly…

By the way which DB did you use?