When I try to update a schema error “INOXRE8888” occurs. The same problem is also reported in servline24 web site (doc id: 223191). But according to that document this problem was there with Tamino 3.1.1 and Windows 2000 Pro. Where as I use Tamino on Redhat Linux Advanced Server 2.1.

Another point is according to the document 223191 the problem was related to those elements with multiplicity “?”. Where as in my case it is not so. The error reported in my case is regarding an element with muliplicity 1. For brevity I attach my schema too (after updation). Error was reported on the element “BIND-object-origin_org” (line no:998 column no:90).

Can anybody help me?

Best regards,
bind_latest.TSD (650 KB)

Hi Gopal

pls provide the original schema for further investigation.


Hi Uli,

Well, I can’t provide it right now as I am suffering from another problem (plz check my post:

I can provide to the original schema once I am through that problem.

Best regards,

Hi Uli,

Here is the old schema.

Best regards,

PS. I launched a support request for the same issue and they are also working on this.
bind_old.TSD (645 KB)

Hi Gopal

I have tried to define the old (bind_old.tsd) schema in Tamino 4.1.
After more that half an hour the _define was not yet finished, and
I cancelled the server.

Then, I defined the same schema in Tamino 4.2 - this took little
more than 10 minutes, and the schema update using bind_latest.tsd
worked without any problem.
I vaguely remember that I did investigate an earlier version of this
schema begin of June, already. The schema is highly nested thus
creating a huge amount of possible paths being checked at _define time.

Unfortunately, I cannot investigate on this issue any more (I’ll be
off for 3 weeks). Here is my recommendation:
- Upgrade to Tamino 4.2 - the processing for highly nested schemas
is much better & efficient compared to Tamino 4.1
- If there is a chance to unload / reload the data it may be helpful
to split the schema document into multiple documents each defining
a single doctype. In case, the doctypes share any declarations
(element, attributes, types), you can use a separate schema which is
included via xs:include (supported since Tamino 4.2)
This will make it much easier to maintain the schemas.

I hope this helps
Best regards