Cannot update a schema

Hello all,

I’ve just posted this to the wrong place (i think), at Tamino X_Plorer. Sorry:

I’m using Tamino on WinXP; and I cannot update a schema (with X-Plorer) just added an element to a sequence. Tamino is saying “INOXDE7956, Invalid modification of components of sequence detected during schema update at line 35”.

I’ve attached both schemas, simple_simple8.tsd and simple_simple8_v2.tsd to this message. The only change between them is at line 37, added a new element (minOccurs=“0”) to a sequence.

The doctype content is “closed”, so i do not know what’s happening… (1.39 KB)

Hi Eladio,
Have done a minimum of investigation and have reproed in version 414.
This is NOT reproduceable in version 421 - the successfull redefinition takes less than a sec.
Is upgrading to 421 an option for you ?

Mmm… I’m talking about a production system with about 1.500 users at 12 places…24 servers with replication…

Any other idea (please,please,please)?


have you tried a “define with instance check” yet? (in the schema editor, in the database menu,
you will find this item)



Hi, Harald

First, thanks Finn for your test.
Where is this option? I think you must be using a newer version of Schema Editor (I’m using version

Thanks, Eladio

Hi Eladio,
The “instance validation” option is also present in the interactive interface TAB for define.
- And I just tested with your schema - it works !

But take care ! doing this update will check ALL instances, so it might take a LOT of time with your big amounts of documents.

I’m not quite sure about this, but I think you should consider setting up maxtransactiontime as well as the size of the journalfile.

In other words do a test with a backup before trying on the prod DB :wink:


Hi Eladio,

the size of the journal file does not matter
- just increasing the “maximum transaction duration” will help if your doctype contains many documents.

Best regards

Finn, Harald, Uli,

If some of you goes sometimes to Granada (Spain), I will invite to him to eat in Alhambra. I speak in serious. Thank you very much, Eladio