Informix wmDB - Can not insert NULL

Hi , EveryOne

I have been using the informix DB , and config the URL in wmDB page .
But when I tried to insert some record to a table using pub.db.insert , It failed , and indicate that I cannot insert the Null to some column.

i >URL: jdbc:informix-sqli://ServerIP:9186/DBName:INFORMIXSERVER=ServerName;
Also. We have created JDBC Connection with informix successfully .

ii>When we use the pub.db.exeSQL , It will be OK.

iii> We indeed mapped all the value to all the columns while the test .

But why ? Any idea will be a great appriciate. Waiting the answer on line .

The problem has been troubling me , I have checked the parameters in pub.db.insert ,including the $dbAlias and the $data ,all of them were mapped value ,
I had successfully invoke it in the same informix DB ,but at that time ,I used ODBC driver.

Any idea will be a great appriciate.:slight_smile:

Is there anybody warm-heart person to help me ?
Infomix , pub.db.insert

Solved ,Finally …

How did you solve the problem at last? The problem has been troubling me. I need your help very much.