Importing the cXML DTD directly

Has anyone been able to get a cXML 1.1.010 DTD working with Integration Server 4.6? I’m not talking about the Ariba OnRamp stuff, I mean just the DTD. I have been trying to do this and have seen (from searching the forums) that there is a known problem with doing that. Some of the data elements get converted incorrectly and generates all sorts of issues. I was able to find that on search…what I wasn’t able to find was how to solve the problem.

I’m not trying to avoid the installation of OnRamp. But i’m just at the prototype stage of a punchout site and would like to do something quick and dirty.

If you’ve been able to import a cXML DTD and get it working with IS can you describe how? Thanks!

Please follow this thread,it might be useful for you.

http://www.wmusers.com/wmusers/messages/117/1649.shtml

HTH.

I tried that…couldn’t get it to work. Specifically, I can’t map anything below the root node – doesn’t find it. When I check to see if they’re null I get a true. Meanwhile recordToDocument generates the same document that I used as input.

I eventually bagged the idea of using the DTD directly, and instead installed the Ariba OnRamp stuff. Worked like a charm, of course.