Human Intervention in Webmethods

I am new to Webmethods. Could someone tell me what is human intervention in webmethods, how to create workflow with human intervention? If possible some sample or document to understand this. Thanks.

Read 9-8_BPM_Process_Development_Help and 9-8_BPM_Task_Development_Help guides from empower.

Yamini – IF you are new to webMethods, then better to start from scratch ( i.e, from developer ). If you are new to BPM then please go through the doc which Mahes has suggested.

Thanks,

I am new to webmethods but was asked to do a POC on human intervention which is indeed urgent. I went through few examples to understand integration server and developer. But need some urgent help for the POC. It would be helpful if someone has a simple example for human intervention.

Yamini – You better go through below links -

https://www.youtube.com/watch?v=5VKEfiz3_IE

http://webmethodsexpert.com/2014/08/16/webmethods-business-process-management-bpm-getting-started/

Thanks,

Thanks for the links MR. I have developed a similar process for PO Approval. But i’m struck at the point of using human workflow. I have a user task in the process but not sure how to configure it to apply human intervention.

Attached the screenshot of the process for your reference. It would be great if you could help me to proceed further.

Please let me know if i have missed something.

Hi,

One more clarification needed. I am using MySQL database in webmethods which is installed in my local machine. When i tried to deploy the bpm process, i get the below error,

Error: Failed while checking database for prior build and upload of process: “{0}” version: “{1}”. Please check the database connectivity in your preferences.
[SoftwareAG][SQLServer JDBC Driver][SQLServer]Invalid object name ‘WMGENERATIONRECEIPT’.
at com.wm.dd.jdbc.sqlserverbase.ddcw.b(Unknown Source)
at com.wm.dd.jdbc.sqlserverbase.ddcw.a(Unknown Source)
at com.wm.dd.jdbc.sqlserverbase.ddcv.b(Unknown Source)
at com.wm.dd.jdbc.sqlserverbase.ddcv.a(Unknown Source)
at com.wm.dd.jdbc.sqlserver.tds.ddr.v(Unknown Source)
at com.wm.dd.jdbc.sqlserver.tds.ddr.a(Unknown Source)
at com.wm.dd.jdbc.sqlserver.tds.ddr.a(Unknown Source)
at com.wm.dd.jdbc.sqlserver.dda3.m(Unknown Source)
… 45 more

When i browsed for WMGENERATIONRECEIPT, i got to know that there are few tables like WMGENERATIONRECEIPT, WMPROCESS, WMPROCESSRECENT, WMSTEPDEFINITION, WMSTEPTRANSITIONDEFINTION.

Please let me know where can i find these tables. Do i need to create them? If so, whats the table structure. Why are these used?

I have installed webmethods 9.8 trial version. It does not include JDBC adapter in it. Can someone tell where i download the installable for JDBC adapter?

Thanks in advance :smiley:

Sure?
Please share the screen shot of the installer where you actually select the products.

Hello Yamini,

Jdbc Adapter does not require to deploy and run BPM process however you need to below things:

  1. WmPRT package installed on IS
  2. Datbase’s table for BPM (you can configure using Database Components Configuration tool)
  3. JDBC pools setup for BPM in IS
  4. In Desginer- BPM Process - Database connection should point your BPM’s IS.

Make sure you have this setup.

Rg, Tanveer

Tanveer – I could see WmPRT in IS. But not sure where to check others. :frowning:

Mahesh,

Attached the screenshots.



Hello Yamini,

I think you have installed all the webMethods products however I can’t see any messaging provider (UM/Broker)… Did you installed this also? (But not mandatory you can use local publishing)

As you have told you can see WmPRT package… Please do the below things:

  1. Recreate or Drop and create database tables(for BPM) by using 'Database Components Configurator"

  2. Configure JDBC Pools in IS for BPM using connection alias to MySql db.(pls see attached).

  3. Make sure from Designer you are pointing to right(Default) IS for Process Audit Database(pls see attached).

Rg, Tanveer


Yamini – I am sorry for late reply, I was quite busy the whole with office work. Please let me know what is the current status of this poc ?

Thanks,

Hi MR,

The POC is still same :frowning: Even with abstract task configured, its throwing error when building the process. Please check my previous post with the error message. It would be good, if you could help it out.

Thanks,

Hi Tanveer,

I have UM installed. Attached screenshot.

When i click on JDBC Pools in MWS admin, it keeps loading. when i checked adapters, i see nothing in that (PFA screenshot).

Currently i installed MySQL in my local and tried to connect from Designer which led to the build error which i have posted in my earlier posts. If i configure JDBC Pool properly and use IS default connection, i suppose my problem should be resolved. Please suggest.

Also, should i configure mws.db.xml
snip4.PNG
Adapters.PNG

Yamini, can you please send a test mail to anynonymoushelper@gmail.com, I wanted to know know some details from you regd the issue to further proceed.

Thanks,