HTTPS posting flat file on a string variable

Hi All,
I have a strange situation here, my vendor is trying to post a flat file in a string to my IS (8.2) via https. In my service i have ffdata as string element in the pipeline. But i get an error: [FFP.0018.0009] Input parameter ffData cannot be null.
at pub.flatFileImpl.convertToValues

The strange situation is the same service works all through the on my UAT environment with no errors. The client is using the same configuration on his test and prod. The Content-Type is set to text/plain by the vendor. I check the server About page and both the UAT and PRod server patches and updates look the same. I also check the mime folder on the IS and both the mimes are the same.
The firewalls are opened, the ports are allow by default.

I have tried everything, i tried setting ffdata as stream, and tried streamToBytes,BytesToString, but still it failed, Saying Stream cannot be NULL, I tried BytesToString, but still got the same error - ffData cannot be NULL.

Could anyone please help me and shed some light on this issue. Seems to be a simple fix, but its really gettingon everyones nerves.


ffdata stream won’t work via http with text/plain…

Basically to check whats coming you can have getTransportInfo as the first step and savepipeline step next and introspect the pipeline. accordingly call the convertToValues with string to bytes or stream conversion.

But I believe you will loose the FF delimiters or format may not be received properly via HTTP method as long it is xmldata and so converToValues not works as expected.


I tried getTransportInfo and savepipeline, but when i restore i get just the transport info and dont see anything else in the pipeline.

The same service is working on test server when ffdata is defined as String in the pipline input and the vendor sends the content type of the file as tex/plain.

So is this the issue in production only? How come it didnt work similar setup?

Did you check with your vendor or in prod env is every thing similar to what you did in Test env?

Can you able to replicate the same test in Test again I mean have them try from their prod to your Test URL?


something i noticed in my error logs :
Whenever they post the ffdata i am getting the following error:

XMLCoder decode invalid data type:

You may need to check with your vendor HTTP and also setup in prod env what different is there part of your trouble shooting:

From the error it sounds either the content type or receive the data thing changed no more string coming might be.