HTTP 401 Error

I am encountering a 401 http error while using the passthru servlet.

If I do a URL request to Tamino directly (e.g. http://localhost/tamino/mydb/mycol?_xql=//document), it will prompt me for userid & password & then return me the document.

But when I do a URL request via the passthru servlet (e.g. http://localhost/servlet/transform/tamino/mydb/mycol?_xql=//document&_xslsrc=http://localhost/test/try.xsl, it immediately gives a 401 http error.

My Apache conf/httpd.conf file is currently set up as follows:
<Location /tamino>
AuthType Basic
AuthName "By Invitation Only"
AuthUserFile /bin/userids
Require valid-user


If I remove the authentication set up in Apache, then any web user can add/modify/delete from Tamino DB which I do not want. Is it possible to use the servlet without removing the authentication set up in Apache?

I’m not at all expert in this area, so forgive me if I’m talking nonsense.

I think the situation is that if the request to the servlet includes authentication information, then this will be passed on to Tamino. So you need to configure the servlet so that authentication information is requested. This is a function of where the servlet is located, together with settings in the configuration files.

I’m sure other people understand this area in much more detail than I do.

Michael Kay