configure Tamino X-Application question

when i configure tamino x-application ,it gives an important imformation:The setup.cmd command script fails if you want to access Tamino XML Server via an HTTP server that is protected with BASIC authentication. To install Tamino X-Application properly, you need an HTTP server without authentication check. Also, you must not protect the collection ino:collection with authentication rights, because the installation process of Tamino XML Server X-Application inserts new schemas.

but in my pc, the HTTP server has been protected with BASIC authentication. how can i set an http server that without authentication check.also what can i do in oder to access the collection ino:collection without the authentication rights.


the installation process access Tamino (its HTTP server) to load the example schemas and the example data.

If you have access to the HTTP server my propose is to
(1) disable the authentication,
(2) install XApplication (invoking setup.cmd)
(3) enable the authentication

After enabling the authentication, it is necessary for running the examples to add a user and userid to the xapplication.xml files of the example directories (e.g. xapplication_4_1_1\examples\jsp\simple\xapplication.xml)

Replace the element

    <tamino url="&tamino_url;">
</pre><BR><BR>by<BR><BR><pre class="ip-ubbcode-code-pre">
    <tamino url="&tamino_url;" user="a valid user" password="a valid password for the user">
</pre><BR><BR>You could also try out to define the entities<BR>'tamino_user' and 'tamino_password' within the file xapplication_4_1_1\xapplication.conf.<BR><BR><pre class="ip-ubbcode-code-pre">
<!ENTITY tamino_user "a valid user id">
<!ENTITY tamino_password "a valid password for this user">
</pre><BR><BR>Then, you could refer from the xapplication.xml to these entries.<BR><BR><pre class="ip-ubbcode-code-pre">
    <tamino url="&tamino_url;" user="&tamino_user" password="&tamino_password;">

Could you try out this solution and check if the simple examples of X-Application work?


thanks for Christian Freytag ,

I have know your way to solve this problem,
but i don’t know the fist step that disable the authentication.

I access to http server with administrator id and password,then i tried to delete the adminstrator id of the directory tree managed hosts->scau-cxt5734ruw->system managerment hub->administrators ,but i failed. it show out the imformation:“last administrator may mot be deleted”.

And how can i do to disable the authentication???

Then i try another way to solved this problem,
1) defind the entities in the file of xapplication.conf.

2)replace the element


in the xapplication.xml,
3) invoking setup.cmd,

but after that ,the xapplication can’t work also,
such as when i test: access http://localhost:8080/xapp/test
it show that: description The requested resource (/xapp/test) is not available.

then i try to invoking setup.cmd again, but it failed also,the information of
fail is:

[echo] Build JSP Examples for Collection: xapplication4.1.1.4


[echo] update application directory D:\Program Files\xapplication_411\examp
[java] cannot delete file D:\Program Files\xapplication_411\examples\jsp\pr
[java] Aborted
[java] updating: D:\Program Files\xapplication_411\examples\jsp\property\WE

file:./misclib.xml:216: Java returned: -1

and what i can do to uninstall the x-application, because i can’t delete xapplication_411 folder directly.

Please help me,thanks.

Hello lisa,

as discussed in your topic at ( I recommend to use X-Application 3.1.3.

Regards, Harald