How to replicate same request from postman?

Hi friends. I tried to use pub.client.http to call REST API and it failed.
When I tried using postman, it works well.
How should I change my mapping?

The pub.client:http has inputs for username in auth , request headers in input “headers” , and body in input “data” which has a table for key value pairs, Hope that helps.

Additionally the error that you get on running pub.client:http should have hints on what is missing.


Please provide a screen shot of your current mapping. Can’t suggest changes unless we see what is in place. :slight_smile:


Hi Zaid,

Kindly post your pub.client:http call input details (screen scrap) taken from your designer workstation for further assistance.



Here is my screenshot.
After a few tries, i suspect it was because of cert not install and after resolve that, i find the error message saying ‘bad request’ now

Few things to check

  • The payload that is sent , compare with the payload of the request in postman.
  • In the call to pub.client:http, the inputs auth->user and auth-> pass are set, there is also a header - Authorization that is set. This looks unusual , please confirm if both (header , auth inputs) are really needed.
  • A bad request typically means that the client is sending something that doesn’t match the server expectations - such as large data when it is not expecting , incorrect format of data etc. Checking the server /error logs in IS Admin UI and the logs on the designer side might have more hints on what is incorrect.


You’re making us guess as to what might be incorrect. Please share the values of the inputs. Obviously don’t share sensitive data but we need to know the values set for method, data/string, headers/Content-Type.

As @Nagendra_Prasad_A_R notes, specifying inputs for auth and setting an Authorization header is redundant but may not be an issue depending upon the value assigned to it.

In any case, to get useful suggestions you’ll need to share the details.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.