How to remove the form="qualified" attribute ?

Hi,

I’m dealing with some web services with contain one or many operations, and looking the WSDL code, I’ve noticed that one of my web service (only one), has all attributes with the ’ form=“qualified” ’ specified.

...
<xsd:element form="qualified" name="idCrediteur" type="xsd:string"/>
<xsd:element form="qualified" name="nomCrediteur" type="xsd:string"/>
...

I’ve read a lot of things about it… but do not understand why webMethods add it automatically (without I asked for it).
http://docstore.mik.ua/orelly/xml/schema/ch10_03.htm

How may I remove this attribute please ?

Regards

Hi Cedric,

are there multiple namespaces involved in your WSDL?

If so, you cannot avoid/remove this information as the elements cannot determine to which namespace they belong.

Regards,
Holger

Thanks Holger,
No, I have only one main namespace
Regards

Hi Cedric,

is this an IS-generated WSDL or an external one?

You can try to export the WSDL to a file, remove this constraint and then recreate the WSD-node.

Regards,
Holger

Hi Holger,

Yes, it is an IS-generated WSDL.

I’ve tried many times, to try to recreate the web service Descriptor in webMethods… but I don’t know how to tell webMethods to not use this “Qualified” attribute.

Maybe is there any problem in the Input Document ?

Do you know in which documentation I can find the reason webMethods create this Attribute please ?

Regards

Hi Cedric,

I am sorry, but I am running out of ideas now.

Regards,
Holger

Is there any difference between soap style/encoding options between the web services U are seeing the difference?

Is the way in inputs and outputs are defined is different?

Can you attach the both WSDLs and IS flow service screenshots masking sensitive details.

Hi,

Making more tests, I’ve understood the problem : It was due to the fact than the Input Document used was incorrect.

Because I did not understand the cause of problem, I’ve explored the IS directory to edit the node.ndf file.
And what did I see inside :

true


        <record name="field_content_type" javaclass="com.wm.util.Values">
          <value name="contentType">1</value>
          <value name="internalType">reference</value>
          <value name="dataTypeVersion">dtVersion2</value>
          <array name="targetNames" type="record" depth="1">
            <record javaclass="com.wm.util.Values">
              <value name="xmlns">http://www.w3.org/2001/XMLSchema</value>
              <value name="ncName">int</value>
            </record>
          </array>
        </record>
        <value name="nillable">false</value>
        <value name="field_xmlns">http://www.mifassur.com</value>
        <value name="form_qualified">true</value>
        <value name="is_global">false</value>
        </record>

so I’ve recreated my document manually, and now all it’s ok :
in the node.ndf I can see form_qualified = false.

I think I probably imported a previous document in webMethods, which might explaining that the attribute was initially incorrect.

Question : Would you know how may I change this qualified attribute from the Designer, without editing the node.ndf file please ?

Regards