How to prevent repopnse on the receiving port

Hello all,

As is for the moment I am receiving XML message on port 5555 and send response generated on port 80.
The problem is that wm 4.6 is sending also something on port 5555. I am using service to clear pipeline, but wm is still sending something. In this case empty XML file. If I do not use clear pipeline sender is receiving data from complete pipeline which is not dropped.

How to prevent response on port 5555 completely?




I don’t think it’s possible not to give any response at all, as a server is always supposed to return some status codes, headers etc. You can however try clearing the response body by using the service pub.flow:setResponse and setting the ‘response’ parameter to an empty string.