How to import jar files to webmethods?

Hello,

How can I import a jar file in webmethods?

I can’t find the import settings for jar files.

On the lib directory, if I put all jar files there, it works normally?

Thanks!

Hi Luis,

You can import the JAR files into webMethods by putting them in the following directory.

  • If it is a generic JAR (means which is used by many packages) then you can place it inside “IntegrationServer/lib/jars” folder.

  • If it is only for a single package, then you can put them inside “/IntegartionServer/packages//code/jars”.

For more information, refer IS Admin Guide.

Place only the required JARs on IS, otherwise, too much JARs can slow down the IS.

Hope this helps.

Regards,
Pradeep

Luis,

What pradeep told is exactly correct and make sure you place Jars correctly

otherwise, it will be usless effort and i don’t think so that jars will slow down server.

Thanks
Sai.

Thanks for help!! :smiley:

Is there any way to add Jar to the server without connecting to the server machine and adding the jars there.
I mean from 8.2 version,when you are accessing the IS via Designer, the designer automatically creates a java project in the name --> packagename[hostname_port].Can I add the jars here directly?
Though I am able to add the jars here and avoid all the error messages pointed ; I am not able to compile the java services(I tried connecting the developer ;edited and compiled);It says the jars are not available
Any idea??

I think you have to physically copy the jar file used by your package to the server’s directory.

1 Like

For Designer, you need both put jar into /code/jars to make compile available and config the build-path of your project to avoid error message.

If you can’t access to server directory from local or remote desktop, you can consider to add FTP port, and then you can put the jar through FTP into any directory belongs to IS.

Hi All,

I am trying to develop the java service to create the excel using the java api poi. I have placed the required jars on the server lib/jars but it was not accessible on my designer. Any other step am i missing. I also tried to place jars to the specific package where i am trying to develop the java service results the same.

After placing the jars i have re-started the server.

Any help would be appreciated.

You must configure the Jar files in the build path of your project in Designer to access the api during development of service.

Thanks Mervin. It works like a charm.

glad it worked!

Hello Mervin and Ashok,
I just read your post here.
I need a help… I placed my jar inside package/code/jars and also configured the build path in designer (i mean i just referred the jar i downloaded in my desktop)

But when i have to move the code to other environments, moving the package will move my jars inside the package.
But how do i do the configure build path in other environments? Also, how can i refer the build path from a common location accessible to everyone in the team?

Can you please help me on this?

Regards,
Kriths

The jars which you setup in designer(build path) are useful only at the design time. In run time they will be fetched from the package jars.

So i don’t think you design in every env. so you need not require. If at all you got to use, you can configure the new env in the same designer so as to fetch the already existing build path.

Answering to your second query - Yes, every developer need to configure the build path. May you can keep the hats in a shared folder and suggest team members to add this folder location in the build path.

Regards,
Naidu

I have created FTP port and i am able to login
when i use ls command service, it is showing the below list
ns
admin
Administrator
replicate

but in the default directory, I have Administrator only.
Extended settings “watt.server.login.userFtpDir=false”

How can i redirect to perticular package?

Go into admin directory, it’s the root directory of webMethods.

Thank you Xiaowei Wang

Thanks Naidu Karri. I got it now!

Once you place the jar file at the package level(/code/jars), make sure you add this property to manifest.v3

package

My 2 cents :smiley:

Hello Community,

how can I import or export processes or a .config date form my client?

thanks!

Hello Community,

how can I connect two processes the first should trigger the other.