How to disable/remove EDA event?

Hi All,

I have an annoying error regarding old EDA event in MWS log (SoftwareAG\MWS\server\default\logs_full_.log).
Because this event is still repeating the error log file is able to reach 20GB per day!

Webmethods 9.12. At this moment task not exists and I don’t use UM (due to license issue only Broker).

How to stop/disable/remove it?

Hi Tomasz,

I think you have three options:

  1. Configure Task Engine not to emit EDA events.
    To get rid of the event that’s currently being redelivered you can
    a) stop MWS,
    b) delete the NERV cache at <SAG_directory>/profiles/MWS_default/cachedata,
    c) start MWS.
    However, if Task Engine’s event emission is not disabled, the same situaton will happen.

  2. Change the com.softwareag.eda.nerv.default.jms.provider NERV property to point to a running (Broker) server.
    The “Modifying the Transport Layer Configuration” chapter of the 9-12_Implementing_EDA_with_Software_AG_Products documentation has instructions for this action.
    Effectively CC will change the property in the following file: <SAG_directory>/profiles/MWS_default/configuration/com.softwareag.platform.config.propsloader/com.softwareag.eda.nerv.properties

  3. Delete or set to null the com.softwareag.eda.nerv.default.jms.provider property. As a result, no default NERV component will be registered, and if Task Engine is still configured to emit EDA events, this will most probably lead to other errors.

I will ask a colleague from the MWS team to have a look, but I think the proposed approaches should work for you.

Best regards,
Atanas

Hi Tomasz,

To disable Task EDA events globally (for all task types), go to Administration → Business → Tasks → EDA Events Configuration, set “Produce EDA Events” to Disabled and save. Effect is immediate, no need to restart.

To disable Task EDA events for a specific task type only, select the Task Type in Administration → Business → Tasks → Task Engine Administration, go to the EDA tab, uncheck the 3 Emit Event checkboxes (Task Created, Task Updated, and Task Deleted), and click the Update button. Effect is immediate.

However if as you say the task does not exist, you may be seeing event re-delivery attempts by Nerv.
If that is the case, options 2 or 3 suggested by Atanas should help.

Kind regards,
Andrey

@Atanas, @Andrey ,

First of all thank you for quick reply.

I’ve checked your suggestions, disabled everything regarding EDA, changed parameters in every “com.softwareag.eda.nerv.properties” file in /profiles.
I even tried to delete event record in WM database - without effects.

I couldn’t find NERV cachedata folder, I’ve no idea where WM store this events.

Finally my solution was….install UM for a moment → event was delivered → logs are clean

Best Regards,