How to disable my webmethod server default login page

I have deployed a portlet in mws.whenever i hit my app url host:8585/my/app , a default login page of webmethods appears. To enter in app i have to enter sysadmin/manage ,but i want to disable this functionality and directly reach to app.Any clue will be really appriciated.

Isn’t it so that you have to be logged in so that MWS can decide e.g. which shell to present etc?

I too have a same issue. Sorry, but i am very new to mws, but to see mws admin page login make sense. But login page appears for deployed app, unless i login webmethod i cant see my app ui. I want to disable for app. Please suggest Any idea, how to do that.

If you do not want to see login screen, then portlets you need to set he authentication scheme as Anonymous.

Login as ‘sysadmin’ user,
go to your portlet or page which contains you portlet.
Go to the permissions UI of the page or the portlet, you will get the Authentication schemes UI.
Here in the drop down select ‘Anonymous’ and click apply.

I am not able to understand how to reach the permissions UI page of the portlet.
Please can you give the steps to resolve this issue.

Even after selecting Anonymous from authentication schemes My WEBMETHODS’s logo is still coming and the input boxes are not visible.
Please can you guide us more to resolve this issue.

Please provide your wM version.

In the permissions UI you need to grant “View only” permission to group “Everyone” additionally to setting the authentication scheme to Anonymus.

Regards,
Holger

WM version is 10.0.

Even after applying the above 2 steps

  1. grant “View-only” permission to group “Everyone”
  2. setting the authentication scheme to Anonymus.

This did not work for me.

Please can you suggest me some other way to achieve this task.
Thanks in advance.

Hi Akanksha,

To not show the My WEBMETHODS’s logo, you need to define shell rule, and define the shell as blank shell for your portlets or page.

If you login as sysadmin you will see a link " Manage Shell Rules" use it to configure the shell. More information can be found in the document https://techcommunity.softwareag.com/ecosystem/documentation/webmethods/wmsuites/wmsuite10-0/My_webMethods/10-0_Administering_My_webMethods_Server.pdf page 324.

Vinay

Hi Vinay,

Thanks for the prompt reply.
I am still unable to skip the default login page of webmethods.

Please suggest me another way to do the same.

Can you send me your application.

I am trying a simple war file attached here.
I want to skip this initial page and the screenshot as well.

TestApp.war (6.5 KB)
intial_webmethod_page.jpg

Hi ,

I just deployed you war file and hit the url http://host:port/app.TestApp.

And it comes up absolutely fine(see screen attached).

Vinay

Thanks a million vinay,

 could you please share the configuration and steps to make this. still i am getting the webmethod logo page without text boxes.please guide me to achieve it as i am a naive for webmethod. Thanks in advance.

Like I already mentioned i did not do any additional steps , i just deployed the war on my MWS and hit url, it just worked.

One thing you may want to check in your environment is shell rule evaluation order , refer the same document I mentioned earlier to understand how to change this. The Shell rule respective to your application move to the first place just to ensure your rule evaluates first.

1 Like