How do we remove ports from Server

How do we remove the ports assigned to the Broker, once it is uninstalled? I am having a problem when I reinstall the Broker on the same port which was used in the previous installation.

I have gone to the registery entry and removed all the entries that webmethods has, but still the ports are not getting removed.

Please help!

Hi, pradeep.

Did you check the registry for references to “ActiveWorks”? Make sure you clean that stuff out, too.

HTH.

Dan,

I have removed all the references in registry entries that has values “Broker”, “ActiveWorks”, “Webmethods”, however there are some keys which I am unable to delete. I was wondering if anyone knew how delete keys any other way.

Thanks
Pradeep

Hi, Pradeep.

If you are on NT, go to Control Panel > Services and tell me if ActiveWorks Adapters 4.0 is still included.

You will also need to manually delete the folder C:\WINNT\activesw and its contents.

Let me know what you come up with.

I

I do not now if this will help you or if it is this that you want, although I sent to you at I see in documentation

The delete subcommand to the broker_config program removes the
Enterprise Server configuration file, all of the data files associated with the
Enterprise Server (and any other file residing in the directory), and the data
directory. When you execute the command to delete a server, you are presented
with configuration information for the server and prompted for a confirmation to
continue. Before you delete an Enterprise Server, make sure the server is not
running. To stop an Enterprise Server, see �Stopping and Starting the Enterprise
Server� on page 85. To delete an Enterprise Server, use this command syntax:
broker_config delete data_dir [-f] [-S]
The following example deletes an Enterprise Server.
broker_config delete C:\wment41\data\awbrokers\server2
The arguments are defined as:
data_dir The path to the data directory for the Enterprise
Server being deleted.
-f Forces deletion of the Enterprise Server without
requesting confirmation. If the Enterprise Server is
running, broker_config attempts to stop it.
-S Silent operation. No output is shown except for
warnings and error messages.

Dan/Rui,

Thank you so much for your information. Let me explain to you how I came to this stage,

I had installed Webmethods Broker using Port 5849, then I had to uninstall the same due to some standard issue. To uninstall I used the Add/Remove Programs option from the Control Panel, which I beleive should have removed all the registery entries also. Then I deleted the Webmethods directory in which the Broker was installed. I also deleted the file in C:\WINNT\activesw. After this I was able to delete only a few entries in the registery, but there are some more keys here which I am unable to delete. If there is a way to delete these entires, I am pretty sure that I can resolve this problem.

So My problem now is how do I remove those keys in registery?

Once again thank you very much for all your inputs

Hi, Pradeep.

First off, great suggestion, Rui. I didn’t know about that option. Cool stuff.

Pradeep… I think you are seeing a normal behavior. If I remember right, the registry will not allow you to delete everything anyway. Don’t know why, but probably to protect any of us from irreparably hosing the machine.

Looking at your registry search terms, don’t forget to look for “Enterprise”, too. I have done the exact action you are trying to take and their were hundreds of total regsitry entries. As always, be careful not to delete too much stuff.

Inside of regedit, search for your terms, delete the individual values in the right-side pane, and THEN delete the container folder in the left-pane.

Hopefully, this will do the job. Good luck.

The old actives are a usual pain, my work around for it on NT is by using the regcleaner tool from winguides.com, it’s free and it gets them out a bit easier than doing it all manual.