How can I Install webmethods tools on Linux box

Hi Everyone,

I have installed WM7.1.1 on linux box from Image file but when I saw page which has list of components then I was socked because there were no names of Developer,Designer and Blaze in the components list . This is the problem, I want to install designer,developer and blaze on linux then how can I do that?

Please reply me soon,

Thanks in advance
Istiyak Vasiwala

That configuration is not supported. The developers tools are Windows only in 7.1. Since Eclipse which is what Designer is has port for Linux, you might be able to get it to run but it will not be a supported configuration.

It’s kind of interesting because I spoke with one of the many development managers at webMethods and he said quite a few of the developers use Linux as the primary development platform. I guess that’s not the IDE group. :confused:

As mark has indicated its not officially supported but we did manage to run developer on Red Hat Linux , you just need to update certain classpaths and it runs perfectly fine.

Did not try Desginer… should not be a problem though.

I was also thinking as to why webMethods has not given suport to Linux based IDE as its just a matter of changing minor classpaths.

Regards,
Sumit

Can anyone give me details to which classpaths I should update to be able to run Developer 7.1.1 on Linux?

Problem is resolved

Can you please post the resolution?
I have succeeded to run Developer but not designer…

Thanks

I’ve tried for a little while now to get Designer to work but can’t. :frowning:

I got Developer working in a few minutes (installed on windows, copied to linux, created .sh script and changed paths).

With designer I’ve tried copying the windows install over, installing manually into 3.4, and into 3.6.

Furthest I got was installing into Eclipse 3.6 (had to hack the ddtek jdbc library for it to be picked up in linux) and follow some of the directions here

http://false.ekta.is/2010/09/webmethods-designer-8-with-eclipse-3-6/

Now I can connect to my IS server, and navigate around the packages. When i try to edit a flow or Java service i get errors, mainly

java.lang.NoClassDefFoundError: org/eclipse/ui/internal/navigator/resources/actions/TextActionHandler

Toying with various plugin versions to get that class back in the classpath breaks other things.

Anyone else get further?

BTW 8.2 works fine on linux (so far)