Help on PSUtilities package

Hi All,

I’am trying to write XML string to file and for that I’am using writetofile service of PSUtilities package. Could you please let me knw how to configure it.

Thanks in Advance.
uwhiz

Hi uwihz,

writeToFile service in PSUtilities has default (allowed write paths) in \IntegrationServer\packages\PSUtilities\config\PSUtilities.So u can mention the required path there.

I dint try this but it may work.

But wat i dint is i copied the service to required folder & edited some code.

// *** Check if path is on the allowed list ***
//try
//{
// if (!checkPathValidity(strFullFilename, “write”))
// {
// throw new ServiceException(“Specified path is not on the write allowed list in the PSUtilities configuration file!”);
// }
//}
//catch (Exception e)
//{
// throw new ServiceException(e.getMessage());
//}
// *** End check ***

The above lines in code i commented & its working fine.

Surya.

Hi surya,

I commented out the code but did’nt worked out . could u plz let me knw hw to tackle this and also let me knw hw to specify path. For the filename field I’am setting the input as C:\Test12\test. test is the filename…

Is that correct. plz help me

Thanks,
Satya

Satya,

A statement like “didn’t worked out” doesn’t help us too much. Be more specific about what you did and what errors you received.

Mark

It is Saying that specified path is not on the write allowed lists in the PSUtilites config file

Hi,

The 2nd thing which i mentioned below is working i.e editing the code…

Can u specify the error u are getting.

Surya.

Thanx fr ur help . Its working nw, but i have another problem nw which is

I’am pulling data from the database and publishing the doucment on the broker and using trigger i’am subscribing that document and i have to write that in the local disk.

These are the steps in the hanlder service;

1)Map set service name
2) pub:xmldoctostring
3) psutil:writetofile

and i’am getting these exceptions com.wm.lang.flowexception while execting the trigger: Rejecting document from trigger store
and in the IS logs it is saying tha com.lang.FlowException at pub:xmldoctostring. I’am successfully able to write it into the local disk when iam using simple doctype when it comes to the doclist which is coming from the DB its throwing this exception.

IF you have any idea abt this plz reply

Thanks,
uwhiz:confused:

Hi uwhiz,
pub:xmldoctostring can convert only document to string not documentlist to string. Loop over the document list and then convert each document to the string and write it to the disk.
Thanks,
Jay

Thanks,

As told by jaya, u can loop over the document list & then write to file.

It’s working fine.

Surya.

Hello can any one help me to find out Sample.io.test:writetofile

without this am unable to write into file
and from where i can find this one " psutil:writetofile"
Plz help me

If you have an advantage site account you can login and search under:

Home > Knowledge Base > Knowledge Base Home > Integration Server 6.5 > PSUtilities Package

Its avaiable for free download.

-Leon

Hi uwhiz;
i m facing same prob help me out .It is Saying that
specified path is not on the write allowed lists in the PSUtilites config file.
i have edited some code as told by surya but after that there is b2b server exeption err.
u have solved this one plztell me

We had the same problem and authored our own or modified PSUtilities

IDataCursor pipelineCursor = null;

try
{
pipelineCursor = pipeline.getCursor();
String directory = IDataUtil.getString( pipelineCursor, “directory” );
String filename = IDataUtil.getString( pipelineCursor, “filename” );
String content = IDataUtil.getString( pipelineCursor, “content” );

if(directory == null)
{
	throw new ServiceException("Input parameter \'directory\' not found");
}

if(filename == null)
{
	throw new ServiceException("Input parameter \'filename\' not found");
}

if(content == null)
{
	throw new ServiceException("Input parameter \'content\' not found");
}

String sep = System.getProperty("file.separator");

BufferedWriter out = new BufferedWriter(new FileWriter(directory + sep + filename));
out.write(content);
out.close();

}
catch(IOException ioex)
{
throw new ServiceException(ioex.toString());
}
catch(Exception e)
{
throw new ServiceException(e.toString());
}
finally
{
pipelineCursor.destroy();
}

WebMethods HOW TO - PSUtilties Errors need Modification

This file needs to be set to allow access to file and directories
Modify this data on wmwin-dev e:/IntegrationServer/packages/PSUtilities/config/PSUtilities.cnf

Once you have modified this data you will have to go to the IS Packages|Management and click the reload button

This will reload the cnf file and allow you to move forward

Dear All,
Im facing an error while im trying to use WritoTOFile from PSUtilities … "Specified path is not on the write allowed list in the PSUtilities configuration file! ",

Please suggest…
I m editing the allowedWritePaths in PsUtilites cnf file , and even im getting the above error.
Pls help me in this.

Thanks,