getting error while looking business rule in MWS

am using webmethods blaze advisor developer to develop the rules
i ahve created the repository in blaze developer.

amd created the project.
created the rules.

i have generated the RMA project to MWS.

sucessfully
deployed to MWS, i can see in MWS Console Administrator—>My Webmethods—>System settings—>Business Rules Settings.

IN Blaze Developer created the repositoiry. with below details.

Repository:CCSClaimRepository
Database User:agservice
Database Password:agservice
Confirm Password:* agservice
URL:jdbc:sqlserver://vms014:1433;databaseName=wmdev

Database Driver:com.microsoft.sqlserver.jdbc.SQLServerDriver

in MWS Console Administration—>Business–>Business Rules.

i can see the Project Name, if i click on project name am getting Rule Maintenance Application screen with below error.

[com.microsoft.sqlserver.jdbc.SQLServerDriver]


Message from webpage

******* Use Ctrl-C to copy this text to the clipboard *******

com.blazesoft.repository.base.NdRepositoryRuntimeException: Could not find class ‘com.microsoft.sqlserver.jdbc.SQLServerDriver’
java.lang.ClassNotFoundException: com.microsoft.sqlserver.jdbc.SQLServerDriver
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:169)
at com.blazesoft.repository.jdbc.NdDefaultJdbcRepositoryAccessor.open(:627)
at com.blazesoft.repository.jdbc.NdDefaultJdbcRepositoryAccessor.openConnection(:587)
at com.blazesoft.repository.jdbc.NdDefaultJdbcRepositoryAccessor.loadRepositoryConfig(:1574)
at com.blazesoft.repository.jdbc.NdJdbcRepository.WjHIPVJ(:220)
at com.blazesoft.repository.jdbc.NdJdbcRepository.getRepositoryConfig(:415)
at com.blazesoft.repository.local.WjIrwOD.(:99)
at com.blazesoft.repository.local.NdLocalRepository.(:71)
at com.blazesoft.repository.base.NdRepositoryFactory.newWorkspace(:251)
at com.blazesoft.template.repository.NdRomFactory.newRepositoryConnectionManager(:538)
at com.blazesoft.template.repository.NdRomFactory.newRepositoryConnectionManager(:371)
at com.blazesoft.rma.NdGenericRMASupport.connectToRepository(:2945)
at org.apache.jsp.initRepository_jsp._jspService(initRepository_jsp.java:335)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:93)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrap

OK

than i have put sqljdbc4.jar file in default(MWS Server Instance)/lib and restarted the instance still am getting same error.

please help me to re-solve the problem.

regards,
anil kumar ellendula

Can you also put this in the url “SelectMethod=cursor”?

URL:jdbc:sqlserver://vms014:1433;databaseName=wmdev;SelectMethod=cursor

Also it is should be sqljdbc.jar isn’t it?

HTH,
RMG

i have set the SelectMethod=cursor .

yes sqljdbc.jar and sqljdbc4.jar file i kept in default/lib folder, still am getting same error.

can you please confirm, am keeping JAR files in right place , am kepping in C:\webmethods80\MWS\server\default\lib, default is my MWS instance, i have created lib folde in default folder, prior to that there is no lib folder in defalut folder, created the lib folder and place JAR files and restrated the MWS.

getting same error.
2. and aslo tried with placing JAR files in C:\webmethods80\MWS\lib.
and retarted the MWS getting same error.

regards,
anil kumar ellendula

  1. and aslo tried with placing JAR files in C:\webmethods80\MWS\lib.
    and retarted the MWS getting same error.

Did you restarted both IS/MWS suite?

HTH,
RMG

Yes, ihave restarted WM suite and getting same error.,

Any suggestions from any one.

am using webmethods webmethods 8.0.1, am sorry to mention that i kept SQL Jdbc jar files in C:\webmethods80\blaze\Advisor68\lib.

please update me the sugestions on this

Hi All,

initially i put sqljdbc.jar and sqljdbc4.jar files in <wm_installtion>\MWS\lib directory

On work around i got the below error in MWS Administrator console.

java.lang.UnsupportedOperationException: Java Runtime Environment (JRE) version 1.6 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0.

than i have removed the sqljdbc.jar file and kept only sqljdbc4.jar file and restarted the MWS instance, now am able to view the business rules from MWS Administrator console.

Thanks for your co-operation
regards,
anil kumar ellendula