FTP PORT command failed

From a command prompt can you manually FTP to same connection?
I’ve seen this when the FTP connection goes down.

the problem is only when I run the service through the Scheduler. In fact problem does not exist when the service is run interactively.

I have already checked the FTP connection manually also… No problems there tooooooo

Appreciate quick help!!!

It might be problem with FTP Sessions may not be closing properly,while the scheduler doing a batch processings.Pls make sure session or connection Open/closed properly, while scheduler job triggers.And also the errors shows Server Socket exceptions.

HTH.

Not sure if this could be similar to your problem, but when we were on an older version of B2B (4.0 maybe?), we had problems with ftp and the scheduler. We would “run out” of ftp sessions available. We had to do a server restart to reset the connection pool. Not a problem with newer version.

I think running the garbage collection job more frequently helped us.

With what version are you seeing this problem?

webMethods Integration Server Version 4.6 + BC46_CoreFix1 is the version I am working on

Currently the problem stands solved! But still wondering what solved the problem, since the server was not restarted. Guess the problem is with the number of open sessions, since it had reached the maximum…

I have currently changed all the FTP’s command with a timeout = 60

Thanks for all the help.

Just curious – how often were you running the Service from the scheduler? Every 60 seconds?

Every 120 seconds !!!

Bhavani,

Read this link and look at the Java code example. http://www.wmusers.com/wmusers/messages/117/1928.shtml
Apparently the only way to stop FTP sessions in a scheduled Service from colliding is to invoke the service using the Java API. If you invoke the service directly they seem to all belong to the same session which is owned by the scheduler.

HTH

I have a FTP client which is submitting files to a IS 4.6 every two seconds. I have about 325 files. The FTP client was developed in VB and working fine till today.

But Today, I am getting the error that says, “Could not create the Data port connection 5556, try passive mode”. The client single thread process that opens the connection puts the file, closes the connection. repeats the process for every file.

Any suggestions on how I can get it resolved??

Thanks
Soujanya

Soujanya: What’s the firewall environment in this case? Has it changed?

Rob,

I am not using any firewall. I was using wmHipaa package and submitting the files to the package using FTP. The Integaration server and system running the FTP client are connected in the same private network and nothing is been changed in the network.

Soujanya

Hi,

My current problem is directly related to this discussion.

I’m using some FTP services on my package, and I have the “FTP PORT command failed” error message. This error message only happens when running my Package, but when trying to use the same FTP services from BC Admin (Management > WmPublic > … > Test Service), it runs fine.

Also, I can test the FTP connection from the command line, and it works fine too.

Inside my package, the problem happens on the “pub.client.ftp:ls”, what is the second FTP Service I use (the first is “login”).

Another information: this problem seems to happen only when I use the Package on a machine after the Firewall (i mean, I have a Firewall between the BC Machine running the Package and the FTP Server).

Some idea?

Thanks!

Pedro

the FTP client tells the FTP server, about downstream communication using port command.

there are two instances when a port command may fail.

  1. If your ftp server does not support PORT command.
  2. the ports that your ftp client specified to the server are blocked by the firewall.

if your problem occurs only when you are behind firewall, then you can ask your network support if they can open ports for downstream as follows:

ftp Server (dataport) => FireWall => YourHost (All Ports)

Chirag.

But I can execute the same FTP commands (like “ls”) using command line or an FTP Application like SmartFTP, and it does not work when running from my package on SAP BC Service.

So I don’t believe it’s a Firewall problem - only if SAP BC 4.6 uses other than common FTP ports for data exchange - is it possible?

What it can be?

Thanks!!

Pedro

Okay,

Let’s take it one by one. On same host, you are able to run ftp commands using other tools?

Is the ftp failing in SAP BC all the time? or once in a while? Is it failing after a service that might have errored out?

Good news!
Seems I solved the problem using passive mode (“PASV”).

Really don’t know why I was able to connect using command line. Actually the connection using other Applications is always too unstable.

Thanks for your help!

Regards,

Pedro

Pedro,
I am having similar problem with my ftp. I am using pub.client:ftp service to connect to ftp site which is outside our firewall. I can connect to the ftp site through command mode. But when I run the service from my package, I get the below error message.

com.wm.net.ftpCException: [B2BCORE.0064.9001]

I am passing the serverhost, serverport, username, password, command (ls) and transfertype as Passive. I appreciate your reply.

Regards,
Roger

Hi ,
I am also facing similar kind of problem. From cmd prompt, I am able to use all the ftp comands without any problems which shows there are no firewall issues. From webMethods service, when I am doing ls using pub.client.ftp: ls
getting wm.net.ftpCException: FTP PORT command failed
The flow of ftp commands are as below in my service
pub.client.ftp: login
pub.client.ftp: cd
pub.client.ftp: ls
pub.client.ftp: get
pub.client.ftp: logout

even in catch block i am closing the connection using pub.client.ftp: logout,In login, giving timeout = 60 .
Anyone can guide me why it happens? we are on version 6.0.1 SP3

Hi,

i am working on webMethods 4.6,we have a scheduler which has to work for every 60 min, but suddenly one day it stops working in production and all the files were stuck in the pending state.and we went to IS-Scheduler. and we opened the scheduler service and pressed “Update task” Button there. and it is started working.

Can anybody have an idea on this, why it was stuckUp Suddenly.