FTP Error Code 600

Hello everyone ,
Could you help us,when our webmethods procedure login a FTP site, it return the error code 600. I search this error code in the google and find that ftp return codes do not contain 600.So why does it return 600 and what this code means , anyone could help me out, thank you very much.

2009/07/29

Normally pub.client.ftp:login svc returns 200 (OK-upon successful session) or 200 series error codes…Also can you ask that remote FTP site owner how its been setup/configured?

HTH,
RMG

Dear RMG
thank you for your kindly help, the remote FTP site say that there is no change at their side. Now I wander if the return code 600 is special for WM which I cann’t find the answer over google . And I really want to know what this return code means, thank you .

                                                                                             conio
                                                                                           2009/07/30

Even i dont know and never got return code 600…its weird…

Did you contacted SAG tech support on this issue?

HTH,
RMg

Dear RMg

Thank you for your great help, I will contact SAG Tech

Dear RMg

Thank you for your great help, I will contact SAG Tech support , thank you very much!

                                                                         conio
                                                                      2009/07/31

If you get any response from SAG,please let this forum also know.

TIA,
RMG

Dear RMG
I also put this question at advatage.webmethods.com ,but there is no answer from it.
conio
2009/08/05

That is unusual error code…so obviously there will be no clue.

-RMG

conio,

did you tried FTP login from command prompt instead of webMethods. Are you getting the same error ?

what is the return message that you are getting long with the error code. FTP return error code, return message and log message. Can you post this.

Can you try login to remote FTP from other system located in the same LAN.

Looks weird though…

Hi all
Even we do face with same issue…in our case we are able to log to Target FTP(with success code 200).

here we are trying to get a 2MB file from the Target FTP, but while the transfer starts its getting disconnecting from Target FTP with errorcode “600” and error message “Lost connection to FTP Server” .

Could any one help me in this??

I never seen FTP errorcode “600” …You should talk with ftp owner or SAG tech support and see what they say…It’s the same discussion in the above thread.

HTH,
RMG

I have now encountered this same error code. My process reported
“FTP Command close failed, return code: 600 - 221-You have transferred 61330 bytes in 1 files.”

SAG seems to be using this code for some default mechanism. Based on this forum thread, there are different FTP servers being used and yet the only common thread among them is the use of the WM FTP client.

Has SAG reported anything on this code?

Can you open new SR with SAG? as no followup/responses been done since the thread started.

HTH,
RMg

I replied in this thread http://www.wmusers.com/forum/showthread.php?t=18941

It’s a hardcoded error in that area.

Then SAG should have defaulted it to false for pass thru any FTP servers via some fix or patch…

good catch though!