FTP over SSL Delivery-FTP PORT command failed

Hello every one

Environment : webMethods 7.1.2
I had a requirement to deliver files using FTP over SSL i.e. FTPS. So i went thru the documentation and implemented below

Approach 1:
1 . Created partner profile and defined his preferred protocol as Primary
2. Exchanged public keys and installed partner public key on partner
profile–>security–>SSL client
3. Asked our network administrator to open port 21 (outbound to remote IP)

Approach 2:

  1. Manually invoked pub.client:ftp service with all the required parameters
    plus ‘secure - auth’ parameter set to SSL and ‘securedata’ set to ‘true’

But both of the above approaches are failing with the below error

[ISC.0064.9008] FTP PORT command failed
By researching little bit on this error i found out that i was able to logon to the remote system and was able to do CD but right before doing the Put i am getting the above error
So is there any other things i have to consider

Please let me know

An add on to my above post

Remote FTP Server personal indicated that their FTP server is able to work with both FTP and FTPS i.e if client request an SSL connection then thats what they get else plain FTP
So i tested with plain FTP and it worked . And i read somewhere that for FTPS the command port would be port 21 and dataport would be some random port greater than 1023 .If thats the case then do you think opening ports >1023 might resolve the issue?


in the pub.client.ftp:login service there is transfertype parameter, try both passive and active, using passive solved similar problem for me last time.
hope this helps.

Thanks for the reply

Tried both active and passive but no luck. With both that types i was able to login to the remote server but getting failure after that


Hi Anil,

were you able to resolve this successfully, if possible can you please let us know how did you do it.

Did you follow approach 1 or 2.