Flat file Parsing errors

Hi All,

Error message:- [FFP.0012.0004] Found no valid records

I am trying to read following flat file.

101,Ravi MALHOTRA,sn rOAD,Smita Malhotra,1234567
102,KN Sinha,MG road,B.k Sinha,5625535
230,Pk banerjee,Park Avenue,Nilotpal Shani,2332323
535,Subhash Agarwal,N.K.Road,Adesh Srivastav,5353622
789,Himesh ,K.l road,Bappi lahari,8989898
877,Asha ,D.A.Road,Sobash Bhonsle,3655625

Record parser i am using is Delimiter
Record character is newline
Field/composite character is ,
Record Identifier is Nth Field

I have created the record and field definitions and also the Extractor field is correct (0-4) for five columns.
MaxRepeat is also unlimited for the record definition.

Plz let me know incase u feel smthing wrong or missing with this.

Thnx in advance.

you have to create the record name as RecordWithNoID (Case Sensitive). Please search for this phrase in the forum and you will find all the details.

Bhavani Shankar

Hi Bhavani,

I renamed the record definition to RecordWithNoID but still i am getting the same error.
[FFP.0012.0004] Found no valid records.

plz help me out…

It should be “recordWithNoID” … try it…



Still getting the same error msg.
any clue!!


Hi Sthita,

with this record definition, there is no need for any record identifier. to give you more info, such a kind of definition of record is to extract records which do not have any record identifiers.

So if you are sure that you dont have record identifiers, then use this option.

Please give the complete setting again for us to help if u face this problem

Please elaborate your existing FFSchemaDefinition details/setup that you have done sofar and upload your flatfile sample and give the complete functional details about your parsing requirements also.


hi reamon/bash,

I have solved the problem.Thanks to all of u.
I went thru the FF document wher its mentioned tht for records with no recordID Dictionary must be created.
I created one
In FFschema i reffered the dictionary by selecting it in dictionary attribute of properties window.
Its working now.

Thnx.Let me know if anybody needs some clarifications.