Failed to start HTTPSListener@5556 error

I got this error while trying to enable an HTTPS port in Integration Server and have no idea what it means:

Failed to start HTTPSListener@5556: (class: com/entrust/toolkit/security/crypto/cipher/TripleDesCipher, method: signature: ()V)

We just got done setting up the KeyStore and TrustStore properly using webMethods 8.2, and after fixing the errors related to those, we got this error. Could anyone offer any insight into what the problem could be? Thanks!

Did you try these steps and match with yours?


================================== Step-1: Openssl rsa -inform DER -in D:\certSetFinal\MyPrivateKey.der -outform PEM -out D:\certSetFinal\MyPrivateKey.pem Step-2: Openssl x509 -inform DER -in D:\certSetFinal\MyPublicCert.der -outform PEM -out D:\certSetFinal\MyPublicCert.pem Step-3: Openssl pkcs12 -export -in D:\certSetFinal\MyPublicCert.pem -inkey D:\certSetFinal\MyPrivateKey.pem -out D:\certSetFinal\Mykeypair.p12 Enter Export Password: manage Verifying - Enter Export Password: manage Step-4: java -classpath C:\webMethods712\MWS\lib\ext\org.mortbay.jetty.jar org.mortbay.util.PKCS12Import D:\certSetFinal\Mykeypair.p12 D:\certSetFinal\Mykeystore.jks Enter input keystore passphrase: manage [for file.p12] Enter output keystore passphrase: manage [choose new pass for file.jks] Step-5: Used Key tool to import the CA certs if you want as trusted certs. keytool -import -file CA.cer -keystore MyKeystore.jks Step-6: At the time of keystore generation the keypair was named as “1”, renamed it from the portecle GUI to Mykeypair and added a password “manage” ================================== Once we did all that and configured the certificates to the HTTPS port and tested it, everything seemed to work just fine.

Thank you for your reply rmg. I tried using those steps to set up my KeyStore (as opposed to using the Portecle as I was doing before) and I got the same error. This time, however, I manage to locate the full error on the stack trace and it looks like this:

java.lang.OutOfMemoryError: (class: com/entrust/toolkit/security/crypto/cipher/TripleDesCipher, method: signature: ()V)

After looking around online for a bit I found out that the OutOfMemoryError means that the server heap is too small. However, I’m having trouble finding information on how to increase the heap size. Does anyone have any ideas on how to deal with this?

Regarding the memory heap size it can be increased (starting from IS8.x) in this file based on your needs:

IS/bin/ or .bat


And restart the IS.



We managed to increase the memory and it worked perfectly. Thank you very much for your help!

OH great: