ETB Not active when I tryed to active the Natural RPC Server

Hi everyone,
I’ve got the ETB not activve problem when I try to start a Natural RPC Server under Linux. The Broker is installed under Windows XP machine. I would like to know if I need to install another component on the Linux machine. The configurations are:
Linux Machine: Adabas, Natural, Natural Security System. Here I start the Natural RPC Server.
Windows Machine: EntireX Communicator. Here I start the Broker nucleus.

Thanks in advanced.


do you have the Broker Stub installed on Linux? It is available as part of the run-time install for EntireX.

Hi Douglas
I just install the EntireX minruntime on Linux and I could solved the problem but I received another related to the environment variable ETBLNK. I already solved it setting the path where the Broker Stub reside after install the EntireX minruntime.
So I’ve got another problem this time when I try to generate an IDL using the EntireX Workbench running on Windows. I received a massages related to the SYSIDL library on which the userid does not have access but it has.
What do you think is happening?
I attatch you a document that contains the message.

Thanks in advanced

20080430 error al tratar de crear generar una IDL desde el WorkBench de EntireX en el Windows.doc (36.5 KB)

Are you sure you have SYSIDL defined to Natural Security? Check the “reason 7” message:

                   - Natural System Message NAT1696 -             Page 1 
   Logon to library :1: for user :2: denied, reason :3:, :4:.               
Tx *** Short Text ***                                                       
   Logon to library ... for user ... denied, reason ... ....                
Ex *** Explanation ***                                                      
   The cause of this error is indicated by the reason code shown in the     
   error message. The most likely cause is:                                 
     Reason  1 - NAT0873: User ID or password is invalid.                   
     Reason  2 - NAT0818: User is not found.                                
     Reason  7 - NAT0806: Library is not found.                             
     Reason  8 - NAT0807: Logon to library ID is denied.