Error with Async Table.

Hello Guys:

I have a problem with my portlet, I have a service done in IS and a web service that contains the service, good, I’m doing drag and drop my webService in my workspace, but when I execute the portlet in MWS, sending error. Could you guide me how to fix this error.

Note: The service when running on Developer works correctly, but when drag on the portlet and execute it sends error. Attachment some pictures for a better location.


Hi Ivan,
I see in your IS response a field named “$connection” which is not defined in the response signature. Could you please remove it from the response and see what happens then?

hope this helps,

Hello Javier:

I’ve made ​​the modification you suggested but still sends an error.
I attached a picture of my portlet, I hope for support.

Greetings and thank you very much.

The problem is related to the use of the character “ñ” in the input of the service. I suppose that it is not correctly handled somewhere in the conversion from Java to the SOAP message. You may want to contact support to get this solved in case you want to use such characters in your property/action names.

I think you’ll get another problem (it will probably popup once you change “Compañia” to “Company”) related to the output of your service. In the response of your service (in Developer) i see you have “SalidaReporte.results.result…” while in your service output you are expecting “SalidaReporte.SalidaReporte”. So you’ll probably get an error once the service runs or you’ll see nothing in your response.

hope it helps,

Hi Javier:

You could clear the error with your support thank you very much.

Now What comment does not paint anything on the table, I tried again to solve this by declaring the output of the service and also have different types of variables declared but still can not fill the table. Could you help me telling me how to solve the problem of leaving the service please.

How should I declare to work out my portlet?

Hi Javier:

I just want to thank you for your support and to tell you that I was able to solve my problem.

What I did was to declare a document map and all variables within an image attached if anyone needs it.