Error When installing Database Component Configurator Core 10.5

When installing just Database Component Configurator Core in 10.5 on 64 bit windows, getting the following error:

13:15:12 info RWP> products to be installed or added to image:
13:15:12 info RWP> 
13:15:12 info RWP> e2ei/11/DCC_10.5.0.0.174/CDC/DatabaseComponentConfiguratorCore : Libraries > Database Component Configurator Core
13:15:12 info RWP> e2ei/11/TPL_10.5.0.0.12/License/license : License > Agreement
13:15:12 info RWP> e2ei/11/WIR_10.5.0.0.184/Infrastructure/CustomInstall : Missing CustomInstall.displayName
13:15:15 error IIR> cannot find entry e2ei,11,TPL_10.5.0.0.12,BM_TPL_WDA-ALL-Any.zip in install image
13:15:15 error APP_ERROR> Installer: There was an error writing to disk. Try to fix the problem below and then select Retry.

Important! If you select Cancel, the installer will exit. If you are creating a new installation, the installation will be incomplete. If you are upgrading, your existing installation will be inconsistent.

Problem: IO Exception: The installer cannot read entry e2ei,11,TPL_10.5.0.0.12,BM_TPL_WDA-ALL-Any.zip from the installation image C:\Users\lmsimpso\Desktop\webM105Windows64_tools.zip
13:17:50 error IIR> cannot find entry e2ei,11,TPL_10.5.0.0.12,BM_TPL_WDA-ALL-Any.zip in install image
13:17:51 alert C> installer is exiting with code: 0

Any ideas? It isnt auto selecting a dependency but wondering if we may have to manually select one.

It complains of a failure to write to disk and an IOException, so I don’t think it’s a missed dependency.
Check the disk space, folder permissions, bandwidth, speed, stability/latency, proxy if you’re using one and also if an antivirus process is scanning the packages as they’re being downloaded.

KM

Thanks, but that isnt the issue. Its occurred on multiple OS’s across multiple developers and it is narrowed down to only this library that causes the issue. Any other components/libraries install just fine so it isnt a disk/permissions issue. And we originally got this when installing from image so not bandwidth/speed/proxy. We get this error whether we are installing from image or installing from softwareag.

Interesting, as it’s usually a network limitation from my experience.
Do create a support ticket to get this investigated further; perhaps someone else will pitch in, meanwhile.

KM

1 Like

A few thoughts come to mind

  • The image zip that was created could lack some entries, this can be verified before installing the image by using “Validate Image” option available when selecting the image to be installed in the installer.
  • If there are other images that work correctly , then you can check the size of the image using the “Image Contents” option , also in the installer.
  • I’m assuming that you are using installer 10.7 to create this image , if yes then selecting all available updates for the components chosen while image creation may help in getting the required libraries/components.
  • Could you clarify what you meant by

Do you mean it is the same error , even when installing directly from the softwareag servers?

  • If none of these work, I would also suggest reaching out to support , with component details chosen during image creation and direct install if that also has the same error.

-NP

1 Like