installation of developer components and other issues


1. I want to install ONLY the developer components of Tamino 4.2.1 on Windows XP pro (Cause I have Tamino Server on RHEL AS 2.1 system). But the installation from Tamino CD (for Windows) doesn’t allow me to do that. I am “forced” to install XTS and BTY too. Since there is no way, I installed XTS and BTY but without giving any values to Directory Server address, port number XTS proxy parameters.

2. As if this problem is not sufficient I did another ‘mistake’. I tried to uninstall my installation (because inoxmld was reporting an error - some ‘dll’ file is missing). During this uninstallation, XTS uninstallation was hanged for a long time without any error msgs nor progress. And then was the blunder done by me. I deleted the whole Software AG directory from my machine. And now I am trying to install everything back - but XTS installation gives the trouble. It hangs!

Any work arounds? Eagerly waiting for help!

Best regards,


Just by trial and error method … I could install again successfully via … Control Panel → Add Remove Programs → Add New Programs → Modify (in the installation dialog). Surprisingly installation doesn’t hang when I proceed this way. Also XTS was not installed.

But … I face problems with X-Plorer. I can’t open database trees. I get “run-time error - java.lang.OutofMemory exception” messages.

Schema editor works alright. But unfortunately it doesn’t convert “my” TSD4 schema to TSD4.2 schema when I switch to TSD4.2 view. Of course, I don’t have the “tsd:accessOptions” elements … but I would have been happy if the number is changed to 4.2.1 automatically :-).

When I try to invoke Data loader it complains that - MSVCR71.dll missing.

In my friend’s computer, X-Plorer is “sometimes” able to open the database trees. But there is something wierd there too. When I run a query from Tamino Interactive Interface (on a database with a default target namespace) the query gets processed very fast. But when I try to execute the same query from X-Plorer’s tool X-Query it is deadly slow. Also the same query is noticed to be equally slow using Java API.

Are there anybody out there who are also suffering like me?

Any suggestions to solve my problems are greatly appreciated.

Best regards,

Hello Gopal,

could you please post the query, and let us know if you are opening a cursor for the results in your Java code?

Thanks in advance,