Error using pub.flatfile.converToString

Hi All,

I’m facing this error when I try to use convertToString service: “java.lang.reflect.InvocationTargetException:com.wm.ff.parse.Converter.cvtToString(Lcom/wm/data/IData;Lcom/wm/ff/parse/interfaces$NodeUsageContainer;Lcom/wm/ff/parse/interfaces$RecordIdentifier;Lcom/wm/ff/parse/interfaces$RecordParser;Ljava/io/Writer;[CZLcom/wm/ff/parse/NodeUsage;Ljava/lang/String;Lcom/wm/data/IData;ZZ)V”

The Req and Flow is like this:

  1. get data from DB Table (has many records)
  2. create schema with recordWithNoID identifier (as I dont have any identifier)
    3)looped with input array as DB Table doc and output array as schema doc
    4)mapped schema doc to ffValues of convertToString – out of the loop
    5)write the string from step 4 to a file on the server

After doing this I am getting the error stated above.

Does this needs any fixes to be installed?

My IS is 6.1_SP2. I tried to figure out the problem in many ways. But still facing the same error all the time.

Please, help me out from this issue as I am new to wM I am trying to get it.
This is urgent for me.


Can some one give me a answer/solution for this issue please???

Can you tell us, what is the target structure of your data, and how have you defined the schema?


Thanks for responding to my query.

The target structure is :
recordWithNoID(doc list) and fields under the list. There are no docs or subfields in the doc list.
The schema is defined as delimiter/newline/~ and starts at position:0

I tried the same service in one of my other servers where it worked fine without any errors. So, i found that some fixes needs to be installed on the server.

Now, i tried installing the fixes on the server but the fix is not being recognized on the server. As I don’t see the fixes updated on the About page of IS console. Also, I am unable to install any fix on my server.

So, can you suggest me something about this issue please?

I am working on 6-1_SP2 version.


Can you tell me the fix name that you are trying to install?


The fix name is ID_6-1_SP2_Fix5 which was downloaded from webMethods website.