Error in using restorePipelineFromFile service to restore soap data

I tried savePipelineToFile and restorePipelineFromFile service for debugging. But when I tried to restore the data from the saved file, and used pub.soap.utils.getHeader to get the header information, an error occured:
[ISS.0088.9118] Parameter soapData must be a valid soapData.
What is the cause of the prolem?
Thanks.

Dear Steven

Even I have faced similar problem while doing a savePipelineToFile and restorePipelineFromFile for the soapData .The only way i could test the service is to see the soapResponseData which gives the actual error .

Regards
Srini

Dear Srinivas,
Thanks for your reply. At present, I’m testing in the same way with you.
I wander if there are methods that can be used to solve the problem, making the debugging more convenient.

Regards

Steven,
Another way to test is to use a tracing tool like, http://www.pocketsoap.com/tcpTrace/ . This way you can see the actual soap message on the wire.

markg
http://darth.homelinux.net

Dear Steven

I have also used a third party tool which was very helpful (SOAP Scope from mindtree ) http://www.mindreef.com/. You can have a look at it also
As you mentioned if some can tell how to fix the restorePipelineFromFile for the soapData it will be really helpful.

Srini

Steven,

Object datatypes cannot be saved in the pipeline. In your case as soapData is of type object, it cannot be saved in the pipeline and hence it is saying paramter soapData must be a valid soapData.

Thanks,
SATYA.

“soapRequestData” though an object is available as a string in the pipeline

Hence one can convert this string to an Soap Data using the pub.soap.utils:stringToSoapData available in WmPublic package
This step could be included in the Test Sequence, which first restores the pipeline and converts the soap string to a soap object.

Further one can work on this soap object !!

HTH
BS