Error in Trading Networks UI page in MWS in 10.1 version

I have installed the webMethods 10.1 licensed version in my system including IS, MWS, TN, DB configurator and Active Transfer. But when I open the B2B section in MWS, it just displays the ‘Http Error response:’ message (See attachment for it). Ran DB configurator too (Used Oracle database) but it still shows this error.

Hi Himaja,

is there anything in the server.log of the IS “localhost” and/or in the full.log of the MWS with a more detailed error message?

Is IS (which is hosting TN) configured to correctly to have the TN function point to the TN database schema?

Please check ACLs on IS for TN Administrators if it contains the correct members.
Make sure you have configured Central Users Management to point to the MWS database.
Please check in IS Admin UI under Settings → Resources if the MWS SAML Resolver URL is correct.

Regards,
Holger

Also verify that server-config.wsdd file in the following MWS location /server/default/deploy/portal.war/WEB-INF/ and checked whether the saml assertion is present or missing from there.

Hi Holger

Thanks for the reply. There is nothing logged in server log and below is the error message from full log file.
2018-08-23 09:31:52 AEST (c.w.p.f.i.PortalServlet:INFO) [qtp1815098333-178] [RID:53] - Request [wl2g0p69fbud1axm2g3bsfoyu:Administrator] http://localhost:8585/webm.apps.tasks.admin.integration.b2b.partners.profiles (POST)
2018-08-23 09:31:52 AEST (c.s.a.p.b.d.D.C.CDS:INFO) [qtp1815098333-178] [RID:53] - [011] Selected INPROC transport for CDS
2018-08-23 09:31:52 AEST (jsf:INFO) [qtp1815098333-178] [RID:53] - HTTP error response:
2018-08-23 09:31:52 AEST (jsf:INFO) [qtp1815098333-178] [RID:53] - java.rmi.RemoteException: HTTP error response:
at electric.soap.http.reference.SOAPToHTTP.invoke(SOAPToHTTP.java:215)
at electric.soap.http.reference.SOAPToHTTP.handle(SOAPToHTTP.java:136)
at electric.soap.references.logging.LoggingSOAPReference.handle(LoggingSOAPReference.java:57)
at electric.jaxrpc.handler.JAXRPCReference.handle(JAXRPCReference.java:76)
at com.webmethods.soap.module.SOAPModuleReference.handle(SOAPModuleReference.java:99)
at electric.soap.references.interceptor.InterceptorSOAPReference.handle(InterceptorSOAPReference.java:69)
at electric.soap.java.reference.JavaToSOAP.handle(JavaToSOAP.java:72)
at electric.soap.java.reference.JavaToSOAP.invoke(JavaToSOAP.java:238)
at electric.soap.java.reference.JavaToSOAP.invoke(JavaToSOAP.java:165)
at electric.proxy.handler.Proxy.invoke(Proxy.java:126)
at com.sun.proxy.$Proxy93.pingTNServer(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

I did everything as per your comment. I added My webMethods Administrators role to Administrators ACL under Central Provider, but still I cannot get the TN partner profiles page loaded in MWS and when I restart the server, the system roles that are configured are gone. And in MWS, in MWS → System Settings → Servers, for the BPM and BAM, I see that the server is unavailable, with error message as ‘No Integration Servers are configured in Central configuration’. Is this something related to the error I see in Partner profiles page? Please help. Thanks.

Hi Shahbaz

Thanks. Checked the server-config.wsdd file and the SAML details are correct and as per your comment.

  1. Verify that Central User Management is showing up as configured in the IS Admin.
  2. Verify that the IS Central Users JDBC pool is pointed at the same database as MWS.
  3. Check the Central Users from JDBC pool whether is configured correctly and successful connect to database.
  4. check in IS Admin UI under Settings → Resources if the MWS SAML Resolver URL is correct & Settings > Extended watt.server.auth.samlResolver=http://localhost:8585/services/SAML
  5. http://:/WmMonitor/ configured with the correct MWS Administrator and password? Please re-enter the password and reload WmMonitor if possible.

IS admin page > Setting > JDCB Pools > Functional Alias Defination > CentralUser, the CentralUser connection to database same schema as MWS,
and test the connection it is connected.

  • IS admin page > User Management > General, it is showing Cental User Management showing “configured”.

  • From MWS getting error “No Integration Servers have been configured in Central Configuration”
    Please try to add the configuration and save it.
    Steps to add the configuration

  1. Click on “Add Server”
  2. DEFAULT NAME
  • BPM only
  • BPM only
  • BPM and BAM
  1. INTEGRATION SERVER (MONITOR) HOST - hostname or IP eg, 10.100.55.22
  • PORT - IS port eg, 5555
  1. ANLAYTIC ENGINE HOST - if you have analytic engine need to configure, otherwise can leave empty
  2. MASHZONE NEXTGEN SERVER HOST - if you have MASHZONE NEXTGEN to configure, otherwise can leave empty
  3. Click “Save” to save the configuration
  4. Click “Check server Status”, it is successfully connected, the INTEGRATION SERVER setting will show green indicator.
1 Like

Thanks Shahbaz for your prompt reply. I tried all these and below are the responses:

  1. Verify that Central User Management is showing up as configured in the IS Admin. – Yes
  2. Verify that the IS Central Users JDBC pool is pointed at the same database as MWS. – Yes, both pointing to same Oracle database.
  3. Check the Central Users from JDBC pool whether is configured correctly and successful connect to database. – Test was successful.
  4. check in IS Admin UI under Settings → Resources if the MWS SAML Resolver URL is correct & Settings > Extended watt.server.auth.samlResolver=http://localhost:8585/services/SAML – This was added to settings and the SAML URL in IS admin is correct.
  5. http://:/WmMonitor/ configured with the correct MWS Administrator and password? Please re-enter the password and reload WmMonitor if possible. – Can open it with the MWS Administrator and password.

IS admin page > Setting > JDCB Pools > Functional Alias Defination > CentralUser, the CentralUser connection to database same schema as MWS,
and test the connection it is connected. – It’s the same and test was successful.

  • IS admin page > User Management > General, it is showing Cental User Management showing “configured”. – Yes

  • From MWS getting error “No Integration Servers have been configured in Central Configuration”
    Please try to add the configuration and save it.
    Steps to add the configuration

  1. Click on “Add Server”
  2. DEFAULT NAME
  • BPM only
  • BPM only
  • BPM and BAM
  1. INTEGRATION SERVER (MONITOR) HOST - hostname or IP eg, 10.100.55.22
  • PORT - IS port eg, 5555
  1. ANLAYTIC ENGINE HOST - if you have analytic engine need to configure, otherwise can leave empty
  2. MASHZONE NEXTGEN SERVER HOST - if you have MASHZONE NEXTGEN to configure, otherwise can leave empty
  3. Click “Save” to save the configuration
  4. Click “Check server Status”, it is successfully connected, the INTEGRATION SERVER setting will show green indicator. – Added the host name and also tried with the IP address, but the indicator is red stating server unavailable. No Integration Servers have been configured in Central Configuration.

Hi

I applied the fixes from update manager and the issue got resolved. Can now open the pages from B2B section in MWS.

Thanks for your help.