Error in flow service Debug

Hi!

Sorry for the nube question, but this issue is a puzzle for me right now.

I’m trying debug a flow service in webmethods designer but i keep getting this message “[ISS.0086.9018] ‘pattern’ is a required input”.

In debug i can see that the exception is thrown in a map that intends to group documents using ‘pub.document:groupDocuments’ and looking at this transformer documetation its says that ‘pattern’ its an optional value for the ‘groupCriteria’, except if the ‘compareStringAs’ value is datetime, but in this case ‘compareStringAs’ is set as String.
1

Further info, while debuging i can see that before getting the error, the grouped document is been correcly poulated inside the map step, and also, the service is succesfull when runned in the aplication environment, the error only happens when Debuging in Designer.

Any help is welcomed.

Thanks and Regards.

Hi Eduardo,

please provide your wM version and the fixes applied, if any.

This helps for searching in the correct version for the case that this happens only for specific versions.

Regards,
Holger

1 Like

Hi @edfx ,
Can you check if you have any other steps in the flow service that possibly have “pattern” as a required input.
If possible please share the full sequence of flow steps.

How are you running this service? from browser? from postman or another client?

What happens when you run the service in Designer instead of debugging , do you still get the same error?
As Holger mentioned, do share the exact version/fixes , it could be occurring only in specific versions only.

-NP

Hi @Holger_von_Thomsen and @Nagendra_Prasad.

I’m using version 9.12.0.0 and i see fixes JDBC_9.10_Fix2, MQS_6.5_Fix37, IS_9.12_Core_Fix2 and IS_9.12_Core_Fix2 under Support > webMethods Packages and Updates in WM webUI.

Sorry to not have mentioned before, i analysed every step in the service before but cound’t find one that requires ‘pattern’ value, and also, i see while debugging that the exception is trown at that exact step and that’s what i’ve found so strange.

I’m running on Designer in ‘Debug as Flow Service’

Yeah just did that, and that way works fine just like via aplication. The problem seems to only hapens when debuging.

Please share a screen shot of the step the calls the transformer. To show what is mapped to what.

A bit off-topic, is there a reason to call this via transformer in a MAP step? Why not just a direct invoke? Calling as a “transformer” is not the issue per se, just curious.

Hi @reamon

Yeah, not sure why project team chose to do it this way.

@Holger_von_Thomsen, @Nagendra_Prasad, @reamon

Taking a 3rd look at the code, i see that i’ve overlooked one mapping step tha explains the ‘pattern input’ message error.

This map step invokes a crossref service to Get a value from database to use as datetime pattern and that’s why the error only occurs when debugging from designer, in that instance database is not loaded so no pattern value is retrieved.

Having the issue in mind, is there any way to load database while debugging in designer so i can watch de code step by step?

Thanks in Advance.

Is this call in the same MAP step as the call to groupDocuments?

Just enter something in pattern and try to run and see the response .I was facing the same and fixed too .Please use this servcie in a step and and show me the Input and output so that I can debug from my end .

1 Like

You may try this .First get the Data from DB using adapter .Next step if you are getting any date from DB convrst that to string in that case you just need to map into a new doc with same filed names but all should be string .Then when you compare as String it will not fail .

1 Like