Error creating a document

Hello,

I try to copy a document generated by a WSDL. Its name contains the character “-”.
When I try to copy this document, I got the not valid name error. "Illegal character - " in my Developer. I use WM 7.1.2.

The document could not be copied or created.

Can I do something to resolve this?

Thanks in advance

What level of fix do you have on your developer?

Cheers,
Akshith

I have the Developer’s Version: 7.1.2.0.124 with ID_7.1.2_Fix8 updates.

For the IS I have:

  • IS_7.1.2_WebSvcsXML_Fix17
  • TNS_7-1-2_Partner_Fix5
  • IS_7-1-2_PkgMgmt_Fix1
  • IS_7-1-2_FlatFile_Fix3
  • TNS_7.1.2_General_Fix3
  • IS_7-1-2_XA_Fix3
  • IS_7.1.2_SrvPrtcl_Fix18
  • IS_7.1.2_PubSub_Fix6
  • IS_7.1.2_Flow_Fix7
  • TNS_7.1.2_Doc_Fix5
  • IS_7.1.2_Core_Fix23
  • TNS_7-1-2_DB_Fix7

ok, In your extended settings can you try to edit the setting
watt.server.illegalNSChars=?’- #&@^!%*:$./`;,~+=)(|}{][><" and remove the ‘-’ in it?
Also restart the server once you make that change. Hope this helps.

Cheers,
Akshith

Thank you akki_84. Yes, I can do this and remove the illegal character -.
Is it safe to do this? Why the “-” is considered as an illegal character?

Interesting questions,

Is it safe to remove this? I am not sure whether it is safe to remove this or not.

Why is it illegal charecter? I read some where that if you have a “-” in a document name and if this document is an input to a java service then it would not compile (never tried it my self).

can someone throw some light on this topic, Forum?

Cheers,
Akshith

Hi, Can someone let me know how Integration Server detects excessive login failures and sends an email alert?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.