EntireX SMH Add Administrator

I’ve got EntireX version running on a Windows 2008 server

I’m an administrator and I’m trying to add new ones as I’ll be leaving the company soon.

When I go to the “Add Administrator” page the tick boxes for SNMP, System Management Hub, Web Services Stack 8.2 and webMethods EntireX 8.2 are all greyed out. I’ve tried filling in user name, but it has no effect.

I know the original administrator had difficulty when she was adding me, but I can’t get anywhere.

I’ve tried deleting all the administrators who have left, but still no luck. however the original administrator is still shown on the “System Management View” tab, even though I deleted her as an administrator.

I know we’re way behind on version number, but upgrading isn’t really an option as I don’t expect the system to be around for too much longer.

Any ideas? Is there a registry setting or system file I could edit to add administrators?

Hi Ian,

I am using v9.6 of the SMH (still the version used for v9.10 of EntireX), so we may have some differences.

Under the Administrators folder under the server name, I have options for SNMP, System Management Hub, Web Service Stack 9.10 and webMethods EntireX 9.10. Is it organized the same for you in your version? if so, expand all of these groups out (click the + sign).

Is your user id listed under all of these? If not, is any of the people listed still around to add you under any you are missing? I think there is a prerequisite that you be an administrator under the System Management Hub before you can add other administrators under other groups (such as EntireX).


Hi, thanks for replying.

Yes my SMH appears to configured the same as yours and I’m listed under all of them

I’m definitely an administrator because I managed to delete the old administrators.

I’ve asked the one other remaining administrator to try and he has the same problem

Can I ask a quick question

If you go to the “Add Administrator” screen, can you tick the boxes without entering a userid? On my screen I can’t tick the boxes at any time, which males me think it’s a problem on the page itself.

One other bit of info, when we first installed it around 5 years ago, we could either logon on using the server name ie http://cpl28mbetx01:10010/smh or log on to the server itself and use http://localhost:10010/smh . At some point, not sure when, the ability to use the localhost url has disappeared. Our security guy thinks that a Windows patch has disabled this functionality

Works for me, but I have 9.5. See attachment.


Good News!!

I spoke to one of our PC support guys about why I couldn’t log on to localhost and he’s tweaked a setting.

When I now log on to localhost I can add administrators again.

The setting was under Server Manager
Configure IE ESC (Enhanced Security Configuration) Tick Off for Administrators

Now when I log on the check boxes can be ticked and I can add new administrators