Credentials on secure broker through SMH

I’ve installed webmethods 8 (EntireX 8 Communicator) on Windows XP desktop. We’re running EntireX 721 on z/OS mainframe.

I’ve successfully installed SMH and and added all my remote brokers. I can access the unsecure brokers and see all the usual information.

I then set credentials on the secure brokers - SMH says that was performed successfully. When I try to view information for those secure brokers I get “No information was found”.

A quick look in the system log on the mainframe side shows that the authorization on the userid for the credentials failed due to password not matched. I’ve already suspended the userid once and had our security group reset the password as well as verify that it is a non-expiring password. I’ve already attempted again to access one of the secure brokers and am again getting ACF2 password not matched errors.

Anyone have any ideas what’s going on here? I didn’t have this problem with the 733 version of EntireX on Windows.

Thanks.

I recall an issue with upper case translation. Try entering your credentials, especially the user ID, in upper case.

Thanks for the suggestion Ralph. I tried it but it didn’t resolve the problem. It still says the credentials are OK and successfully set but still doesn’t show any information for the broker and system log still shows password not matched error.

what version of z/OS are you running?

On your Windows XP desktop, try setting the environment variable ETB_STUBLOG=3 and restarting SMH (Software AG Common Tomcat, CSLayer, Event Layer…or just reboot!). (you can also set ETB_STUBLOGPATH to specify the location of the trace file).

Check the log after to see if there is anything apparent - is the error being returned to SMH? If not, a support request is probably needed to investigate.