Email port stale connection

Hi everyone,

We are working on webmethods 7.1 version and having an email port with multithreading set to No.
It is basically reading each mail one by one and processing them.

It was working fine from few days but suddenly we found that the port is working intermittently. It works and processes mails for some time and after some time it stops working on its own even though the port is in enabled state. After the port stops working, we need a manual intervention and refresh the port manually to get it running again.

Any sort of help will be appreciated

Thanks,
Amit

we experience similar issue with email port.
Our work around is to reset the email port periodically.
You may also contact software AG for a fix.

Hi Amit,
A stale connection might occur for different reason. Do you have a firewall in place? It would have a ‘connection timeout’ setting configured which will detoriate the connection if there is no data transfer happened which the end system that established the connection wouldn’t know. Hence manual intervention of enabling and disabling prevents the problem.

-Senthil

Hi,
I am also facing similar problem. We have firewall also in between but connection gets unresponsive sometime though emails are keep on coming to that mailboxes and connection is enable but we need to manually enable and disable the connection in order to process emails.
My question is : Is there any specific limit that a particular email port can poll specific no of email in a minute?

Hi Vikas,
‘Time interval’ property is there to check how often IS has to check for emails.

From documentation:
“If the e-mail port is configured to allow multithreading and if the e-mail port receives a large number of messages in a short period of time, the email port will monopolize the server thread pool for retrieving and processing messages. This will slow down the performance of Integration Server. To avoid this, you can limit the number of threads used to process messages received by the e-mail port by setting the watt.server.email.waitForServiceCompletion property”

-Senthil

Hi Senthil,
Time interval is 20 seconds and we are not using multithreading.