Email Port is not getting enabled in wM 9.5

Hello Experts,

Need your help in configuring email port in webMethods 9.5 environment.

Please let me know what needs to be done in order to enable email port in IS.

Type :- IMAP
in gmail imap host.

Let me know if any further info required.

Thanks,
Yogesh

Can you please read the IS administrator guide and then post if you have any issues/errors :slight_smile:

Hi Mahesh,

Already set below property in startup script

-DWM_HOME="%WM_HOME%" -Dmail.imap.socketFactory.class=javax.net.ssl.SSLSocketFactory

and getting below error while enabling the email port.

Failed to start EmailListener:imap:ABC@XYZ.com@imap.gmail.com: [ISS.0070.9003] Enable failed: Could not log into account ABC@XYZ.com@imap.gmail.com

Share your email port configuration screen shot…

I assume you don’t have any network block or firewall issues.

You need to create a HOST in the exchange server with user_id and password.
IS will try to login in exchange server with user_id and password defined by you. I suspect that you are getting error because of that as Integration Server not able to establish the connection with exchange server.

After completion of above task you can put your flow service name in Global service or default service as per your requirement.

Please correct me if I am wrong.

Hi Vicky,

I have already created one user under ABC@imap@XYZ.com and also added the SSL argument in startup script but still not able to enable the port.

P.S. Same port is enabled in wM 8.2 environment but not in wM 9.5 environment.

Thanks,
Yogesh

Hi Yogesh,

Please check if the proxy rules and firewall ACLs are correctly created for production server to exchange server. Since the mail is going out over internet outside your organisation via firewall , a rule must exist to allow that.

The port , source IP must be created in outbound firewall rule.

Perform some basic network test. Let us know your findings.

Regards,
Namit Verma

Hi All,

Thanks for your comments.

Issue resolved after adding SSL argument in server.sh file under WM_InstallationDirecotry/IntegrationServer/bin (In WM 9.5 Version)

BUT

In WM 8.2 Email port is working if we add SSL argument in startup.sh file under WM_InstallationDirecotry/profile/IS/bin.

Best Regards,
Yogesh

Can you please share the line of code [SSL argument] that you added in server.sh or startup.sh

Hi Mahesh,

We are using implicit SSL in our IS with 993 as default IMAP port and adding below parameter in startup script
-DWM_HOME="%WM_HOME%" -Dmail.imap.socketFactory.class=javax.net.ssl.SSLSocketFactory

Let me know if any further info required.

Regards,
Yogesh