Hi All,

We are facing a issue while receiving the payload (inbound to us) EDIINT signed data from partner. For processing inbound data from partner we use the inbound:processMsg standard service. But, the service is failing with Error “Either security check failed or error/warning occurred while processing inbound message.” And as well “Payload is not processed.”

I suspect we have a problem while wm.tn.mime:processEncryptedData service as the output of this service is FALSE

Please help us here if anyone faced the same issue before.

Shafi :slight_smile:

please share your thoughts if any


Assuming that your client system is sending AS2.
normally it’s signed and encrypted.
you need to configure the certs for signature verification and decryption, check that, they also need to be the same certs that your client system is using.
Hope this helps,

Check Your Configuration First

The Reciever profile(Your Profile) shoould have your public certificates set and private key also set,

The Sender Profile should have the partners public Certificate set.

If this is ok

Call the sender and ask to verify if they are using the correct certificates.(You could read out the expiry dates to confirm if both of you have the right certificates)

In my experience 90 % of such connectivity issues are solved on the phone (due to people putting the wrong cert in the wrong place)

Thanks for reply, helped me a lot

I know these are issues with mutual hand shake configuration with keys.

When i checked the key configuration at MWS partnet profiles , found that the profiles are missig with private SSL keys. When i tried to add the private keys to inbound profiles. Its throw error called “java.security.InvalidKeyException: cant parse privateKeyInfo”

I am sure whether still certs are proper or any other configuration causing issue

Please share if any ideas here


Any update on error “java.security.InvalidKeyException: cant parse privateKeyInfo”

i am getting this error while importing the private Key in .key format for partner profile at MWS

Please help here.


Guys, this issue got resolved after adding the SSL private key to Profiles.