Has anyone been able to use the DELFOR 96A schema and template to generate a Values object, when the input DELFOR has Segment Group 4 and not Segment Group18?

Thanks for all the help,

You need to modify the DELFOR 96A record structure itself by renaming the UNS segments and forcing to use segment group 18.



This is the work around to do that…

There is a fix that takes care of it, and some other problems in DELFOR96A as well. I think it is called WmEDI_4_6_Fix6.zip. I can send it to you if you want to.

Best regards,
Beatrice Nilsson


we contacted wm support at that time they didnt told us about this fix…and later we tried it manual way changing the record structure and it worked fine.

But are you sure that this fix will resolve regarding the DELFOR 96A issue?



We had the same problem in October last year, I think webMethods created this fix then to solve it. This is cut from the readme file of the fix:

This fix addresses the following issues:

  • (Trax:1-9NO1T) Trailing field delimiters are not removed.
    If a trailing field is not null but is a string with a length
    of zero then this problem will occur.

  • (Trax:1-9LUC9) addICEnvelopeEDIFACT adds extra chars at end of
    a UNE segment. The content will be placed under UNB as
    “unDefData” to fix this problem.

  • (Trax:1-9K27M) When an EDI string contains multiple release
    characters, only the first release character is parsed

Could it be that you asked for it before we did, so the fix did not exist at that time? I also tried to change the record structure, but that created new problems.

Best regards,

Is that fix for Outbound DELFOR 96A?

The issue above is for receiving inbound DELFOR 96A when convertToValues the values object is creating a mess up.

Thanks for your reply.

It works both ways, seems like the shipped template for DELFOR is corrupt, so you need to install the fix and then regenerate the template from a SEF file.


got it.


Hi All,

Where can i get SEF file for the DELFOR 96A schema.?
How can i edit it and generate new schema again.?
Please help me to get SEF file …



We have created a flat file schema for DELFOR based on 96A.SEF in webMethods 6.1, still it is not creating the flat file schema correctly. Could anybody help on this. If somebody have the fix , could you please send to me.

Thanks & Regards
Naveen Kumar.G