Doc Publish Errors


I am creating a flow service that only contains ONE step: pub.publish:publish. In the flow service, I have a document reference as an input. In the pipeline, I map my document reference to the document reference that is contained in the “document” variable of the publish step. I have also filled in the documentTypeName.

When I debug the flow service, I get the error

Caused by: [ISS.0098.9007] Data does not conform to the Publishable Document Type errors: INVALID
List of errors:
[0] pathName=/requestorID errorCode=VV-005 errorMessage=[ISC.0082.9034] Field is absent, field must exist

I don’t understand why this is so since at the start of the debug, I specified values for ALL inputs, including requestorID. Why does it say the field is absent?

I then tried to revise the pipeline. Instead of mapping document reference in the “Pipeline In” to “Service In” of “Publish”, I mapped EACH variable in the document reference in “Pipeline In” to EACH variable in “Service In” of “Publish”. Debugging the flow service gave me the same error.

Can anyone tell me what I am doing wrong?

I have attached an image, named mapping.jpg, to show the mapping of variables in the pipeline for my service.

Thanks in advance.


Try to map your input document “nomination” directly with “document” in the publish service. You don’t need to define the document structure in input of the publish service (remove “nom”). Have a look on the attached screenshot, that’s how I handle it.