Different behaviour between normal en stepping through a flow

I ran into a weird problem, I have different behaviour using the same flowservice and input. When testing exception handling - I forced the service into error by giving it bogus input, therefor logging the error to the database and the serverlog.

When going through the flow using ‘steps’ and TraceToHere (end) in developer everything works fine, flowservice throws an error and the catch clause logs it to the database and the serverlog. When using the modeler and the catch steps are part of an error step service it also wokrs like a charm.

When doing exactly the same thing in one go using developer - same input, same error nothing gets logged to the database ? But it does get logged to the serverlog. ALso when using a trigger - different behaviour.

In all cases monitor shows the same stack

What can be the reason on different behaviour on the same flowservice when using step of ‘normal’ mode ? Are there standard pub services that may act this way ?

Is this service or any other one along the way using cached results. They may be getting preserved in your session and popping back out at that point.

Good day.

Yemi Bedu