Deployment : deletion order set in the map

hi,

In the Deployer, I have a little deletion action to do (a single service), and then add some new services
that I would like to execute within the project :

I’ve created a Project with 2 sets (in that order) :
1- a deletion set (Source : IS_preprod)
2- a deployment set (source : IS_Dev -> IS_preprod)

Curiosly, after adding sets, the Deletion Set appears after the Deployment Set ?

In addition, when I arrive in the Map section, I see the Deletion Set appears after the Deployment Set.
I’m worried while the documentation is maybe not precise enough about order of deployment sets.

How may I be certain that the Deletion actions will execute “before” Deployment actions please ?

Regards

…or maybe i’m not using the good way ?

Hi Cedric,

you can try the following:

  • remove the deletion set
  • specify the files of the service and its directory under the “Files to delete” link in the regular deployment set.

Make sure to specify the files first and then the directory.

A flow service is using a flow.xml, flow.xml.bak and a node.ndf.

Regards,
Holger

Thanks Holger,

but the deletion has to be applied on my target IS_Preprod, while the regular Deployment is from IS_Dev.

So in the Deployment set, I have to select 2 Source servers : IS_Dev and IS_Preprod ?

Regards

Hi Cedric,

no, this is not neccessary.

You only need to define the IS_Dev as source and IS_Preprod as target in the Map.

Even for a Deletion Set, you should define IS_Dev as source and then map IS_Preprod as target.

When you create 2 Maps (one for the deletion and one for the deployment), you can control the order of their execution as Deployment Candidates.
You will get a warning about incomplete maps, but this can be ignored as it is intentional in this case.

Regards,
Holger

Yes, I think I understand Holger.

But if I select only the IS_Dev source, I will not be abble to specify the files to Delete, because the old files exist on the IS_Preprod, but do not exist on the IS_Dev. So I can not select them.

Regards

Hi Cedric,

when deleting files/service in a normal deployment set, there is a text box in which the names with path (relative to the Package base folder) need to be specified manually.
One file per line.
The file paths start with “ns” followed by the path to the service. Unix directory separator “/” can be used even on Windows systems.

In this case the files do not have to exist on the soure system.

Regards,
Holger

Oh, I understand… I’ve thought, because the file was not displayed in the files listed, the Deployer will not be abble to delete them from the target…

Thanks again Holger.

Regards

It was an example isn’t it ?

In my current case, I will have a single map because it contains a regular Deployment set (and files to delete) ?

Regards

Hi Cedric,

when there is only one deployment set you are right.

With the 2 Maps I was referrring to the original request with one deployment set and one deletion set.
In this case you can define separate maps for each of them and deploy them in any order you want.

Regards,
Holger

Thanks for your Holger.
Regards

I’ve created my set with specifying files to delete, but the Build fails because the Deployer do not find the files and directories on the IS_Dev file system :

2016-03-03 16:07:30 CET	ERROR	[DEP.0001.0042] Integration Server package files ns/...folder1.../node.ndf, ns/...folder2.../node.ndf do not exist. Use the Deployer user interface to verify and edit the list of files for the package.

Am I missing something ?

The Deployer can’t continue without the success of the Build step

Regards

Hi Cedric,

can you provide some screenshots of your DeploymentSet?

Especially of the section “Files to delete”.

Regards,
Holger

Preparing the screenshot… I’ve realized that 2 old files was still in the Selected files section.
They should not appear there because I have deleted them from my IS_Dev…
So I’ve just restarted the IS, and now that’s OK.

I’m my fault, sorry.

Regards

Hi Cedric,

please check your deletion list.

Folders usually do not have a node.ndf but a node.idf.

Java Services consist of node.df and a java.frag file.
Flow Services consist of a node.ndf, a flow.xml and a flow.xml.bak.
DocTypes, AdapterServices and Triggers only consist of a node.ndf

You must specify all files for the appropriate object for deletion as otherwise the folder for the object wont be deleted.

Regards,
Holger

Thanks a lot Holger, by chance, all the bad named files was placed in a folder directory to delete.
So all deletions have worked well :slight_smile:

Regards

Hi Cedric,

did you verify that on the target filesystem?

If there have been files overseen for deletion or if they are specified in wrong order, the folders remain in the file system being empty.

Regards,
Holger

Hi Holger,

You’re right, looking on the file system, the folders have not been deleted.

I do not understand, reading the documentation, the folder must be suffixed by “/”
but after saving, the folder item disappear from the list :

Example :
-> Before Saving :
ns/mypackage/adapters/Adapter1/node.idf;
ns/mypackage/adapters/Adapter1/;

-> After Saving :
ns/mypackage/adapters/Adapter1/node.idf;

Any idea why ?

Regards

Hi Cedric,

does it help if you omit the trailing “/”?

Evtl. you have to use a newer Fix for Deployer (if there is any).
Remember to update the WmDeployerResource-Package on all instances after patching the Deployer.

Regards,
Holger

Holger, unfortunately not, if I try omitting the trailing “/” and save the screen set, the only selected file showed to the left is for the .idf file (no line concerning the folder).
After going again in the “Select files” option, the field contains only one item :
ns/mypackage/adapters/Adapter1/node.idf;

Regards